Atelier

Syndicate content 80 

Mark All as Read

Suppose I want to create an Eclipse plugin designed to be added to Atelier, and my plugin needs to perform some processing on the server that the current Atelier project is configured to connect to.

Is there a way I can use the connection credentials that have already been entered by the user? I don't really want to make them enter these again into my own plugin.

Last answer 2 March 2017 Last comment 22 September 2017
+ 1   0 2
368

views

+ 1

rating

Well my last post got cut off for some reason. I am trying the new beta and wondering about the following functionality from Studio that I don't find in Atelier:

F12 = Open the routine and jump to the tag of the current call the cursor is on in a routine

F2 / <Ctrl> F2 = jumping to a bookmark / toggling a bookmark

<Ctrl> G = Jump to a tag in the code

When might these things be in Atelier? I use them a lot in Studio and the absence of these really slows me down.

Last answer 31 January 2018 Last comment 31 January 2018
0   0 3
269

views

0

rating

Hello,every body. 

I am having a problem when using atelier. I found that the web front-end related files (such as csp, css, js, etc.) will change in format when they are synced to the server.

For example:

The original format of the js file may be UTF-8. However, when I edited and saved in atelier, the file version format on the server became ANSI. I tried to configure the environment in eclipse, but it doesn't seem to work.

E.g:

Last answer 7 August 2018 Last comment 8 August 2018
+ 1   2 2
181

views

+ 1

rating

Is is possible to install multiple copies of Eclipse/Atelier, and have each instance maintain it's own distinct list of server connections? I thought I had figured it out, uninstalled everything, and reinstalled without using bundle pools.  I think this keeps projects separate, along with allowing different Eclipse settings and plug-ins. After installing the second instance, no server connections from the first were showing in the second.

Last answer 26 March 2018 Last comment 28 March 2018
0   0 4
233

views

0

rating

Hi,

I have an Atelier question.

I have a routine developed in Studio to upload a tab-delimited text file to process using Objectscript into Cache.

In Windows, to upload the file “test.txt”, I used the Objectscript commands,

Last answer 27 January 2018 Last comment 28 January 2018
0   0 3
170

views

0

rating

In response to a comment on his posting about source control hooks and Atelier Bill McCormick used the example of Studio's SOAP Wizard and talked about providing more information about how Atelier will support this kind of extension.

 My Atelier (1.0.116) has a Tools menu with an Add-Ins option and a "Soap Wizard" (sic) submenu.

Is there any information available to us yet about how we can add our own add-ins of this kind?

Last answer 5 January 2017 Last comment 5 January 2017
+ 2   0 4
323

views

+ 2

rating

Hi there.

I'm really interested in using Atelier for its source control ability, and I have found a fair bit of info when it comes to starting a new project and then pushing that project to a chosen source control system.

However, my environment has a lot of existing code which was developed within Studio and Ensemble, and placing entire namespaces within a single project file feels wrong.

Last answer 16 May 2018 Last comment 18 May 2018
+ 1   0 5
267

views

+ 1

rating

Thanks a lot, that we finally got the new version of Atelier, where most of the errors were fixed.

But I've found some have not fixed yet.

    set destination = $listget(waypoints,*)
    set $list(waypoints,*,*)=""

In this code, Atelier does know about asterisk as a second argument to $listget function.
And in this case, even shows next lines as an error.

Last answer 17 November 2017 Last comment 13 December 2016
+ 1   0 1
401

views

+ 1

rating

As part of our security standards, we can't have our applications saving our credentials. For Atelier, this means our server connections. Is there a way to stop this by saving the connection parameters, but prompting for credentials on each run? Or is there another way?

Thank you

Last answer 19 June 2018 Last comment 18 June 2018
+ 2   0 3
342

views

+ 2

rating

Hello everyone,

I'm using Atelier 1.3. When we configure a server and use HTTP to connect, works fine. But when we activate the Secure connection option I get the Unregonized SSL message, plaintext connection?

Do I need to perform any configuration on my server so that Atelier can access a secure connection?

Last answer 2 January 2019 Last comment 7 February 2019
0   1 4
203

views

0

rating

Hello everyone,

 

I'm trying to migrate the IDE for programming in COS, we normally use the Studio, but we want to use a more modern IDE. Our team has knowledge with Visual Studio plataform, but we couldn't configurate the compiler and terminal, I installed the extension InterSystems ObjectScript and tried to configurate to connect with my local machine, unfortunately the connection don't sucessed.

Someone has material for how i can connect and compile? Some material i saw show how to use the compiler, but not how can i do the configuration.

 

Last answer 3 April 2019 Last comment 8 April 2019
0   0 3
348

views

0

rating

I want to demonstrate using Git via Server-side Source Control hooks (to allow both Studio and Atelier to access a Shared Dev namespace), and I was planning to use the popular Caché Git hooks:

https://github.com/intersystems/cache-tort-git 

Last answer 2 September 2017 Last comment 30 August 2017
0   0 2
392

views

0

rating

I am trying to use current implementation of source Control for Cache Studio in Atelier, but UserAction = 3 "Run an EXE on the client" is not working. Basically Atelier is launching a "page" using the target as url.

Am I missing any settings in order to command Atelier to run a exe command instead?

Cache Version: Cache 2017.2.0.744.0

Platform: Windows 10

Last answer 28 March 2018 Last comment 29 March 2018
0   0 4
175

views

0

rating

I am having trouble configuring the environment in eclipse have download eclipse  for java script and web developers  followed the video but could not connect to the server I have my Apache server 7.0 added to the java environment and I can start and stop the server through eclipse IDE but when I fire atelier and add server I get the above error any help please .This is the first time I am trying to use the plug in through eclipse .Just in case There is another installation I need to do please advice but I am guessing something to do with atelier not seeing my configurations or permissions

Last answer 10 August 2018 Last comment 13 August 2018
+ 1   0 4
162

views

+ 1

rating

Hi,

When i try to configure my server connection in Atelier (Eclipse), i am getting the below exception.

java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

It was all working fine and i think that the only thing which i have done was installing some windows updates. Now when i try to configure the server configuration i started getting the above error, any suggestions to fix this?

Thanks,

Last answer 10 June 2018 Last comment 5 July 2018
0   1 2
216

views

0

rating

Hi,

I am having a problem in REST service when de-serializing JSON using a nested Property.

I am new to Intersystems and my first time creating REST Service. I setup Atelier dev environment. The worst IDE I have ever worked in. I was able to  attach to a process in the debug perspective and step through the code, but one cannot see contents of variables nor print anything to the console, so it is useless as a debugging tool. When looking at a variable all it displays is its type of the variable and if I try to "watch" I get:

Last answer 24 February 2019 Last comment 25 February 2019
0   0 2
165

views

0

rating