Atelier

Syndicate content 80 

I've installed Atelier according to instructions but after rebooting Eclipse there is not opportunity to launch Atelier. In preferences there is not Atelier. I've tried to update and reinstall Atelier but it didn't get a result. I checked it was installed on my PC. 

How can I solve this problem? And why I faced to this situation?

All needed components were been installed earlier.

 

Last answer 1 October 2019
0   0 1
0

comments

42

views

0

rating

Hello everyone :-)

I would like to update Atelier from version 1.0.262 to the 1.3 one. So I clicked on Help --> Check for updates, and I get these first error messages:

"No updates were found in available software sites."

"Some sites could not be found. See the error log for more detail." etc. cf picture below talking about Proxy Authentication.

Last answer 16 September 2019 Last comment 30 September 2019
+ 1   0 4
87

views

+ 1

rating

Hi All,

I've got Eclipse installed (Javascript 2019-6) but when search for Atelier from the market place within the IDE it does not show up.

I found it in the browser version of the marketplace, and tried to drag it in but got the message 'The following solutions are not compatible with this version of Eclipse'.

I tried installing an older version of Eclipse (photon) but the installer keeps telling me I haven't got JRE 1.7+ installed (I have 1.8 64bit installed already), and sends me to a download page so I can't continue.

Last answer 8 July 2019 Last comment 9 July 2019
0   0 2
118

views

0

rating

Hello everyone,

 

I'm trying to migrate the IDE for programming in COS, we normally use the Studio, but we want to use a more modern IDE. Our team has knowledge with Visual Studio plataform, but we couldn't configurate the compiler and terminal, I installed the extension InterSystems ObjectScript and tried to configurate to connect with my local machine, unfortunately the connection don't sucessed.

Someone has material for how i can connect and compile? Some material i saw show how to use the compiler, but not how can i do the configuration.

 

Last answer 3 April 2019 Last comment 8 April 2019
0   0 3
339

views

0

rating

Hi,

I am having a problem in REST service when de-serializing JSON using a nested Property.

I am new to Intersystems and my first time creating REST Service. I setup Atelier dev environment. The worst IDE I have ever worked in. I was able to  attach to a process in the debug perspective and step through the code, but one cannot see contents of variables nor print anything to the console, so it is useless as a debugging tool. When looking at a variable all it displays is its type of the variable and if I try to "watch" I get:

Last answer 24 February 2019 Last comment 25 February 2019
0   0 2
162

views

0

rating

Hello everyone,

I'm using Atelier 1.3. When we configure a server and use HTTP to connect, works fine. But when we activate the Secure connection option I get the Unregonized SSL message, plaintext connection?

Do I need to perform any configuration on my server so that Atelier can access a secure connection?

Last answer 2 January 2019 Last comment 7 February 2019
0   1 4
200

views

0

rating

Let Say I have 
Class Carrier Extends %Persistent

Property Employee As Array of Class Employees

Class Employees Extends %SerialObject

Property Name As %String

Property Address As Array of Class AddressDetail

Class AddressDetail Extends %SerialObject

Property Street1 As %String

Property Street2 As %String


I can get value for Employee Name  as Employee_Name.

But I want to Get Value of Address Street1 and Street2 of Class AddressDetail using SQL Query
How can I get that?

Last answer 18 January 2019 Last comment 25 January 2019
0   0 2
175

views

0

rating

​​​​​​​Hi, 

I've been going through the instructions at https://download.intersystems.com/download/atelier.csp  

Our development team are on the main hospital infrastructure so we need to whitelist any plugin repositories that Eclipse will need to get updates from.

I believe I need to whitelist the sites that host the both the Atelier and Eclipse plugin repositories:

Last answer 28 November 2018 Last comment 17 January 2019
0   0 2
157

views

0

rating

Hello experts, 

I am new to IRIS and I was told I could get a great hands-on experince with the commuity edition that is currently availabe on mutliple cloud providers.

Unfortunately connecting Atelier to the given IRIS instance has been unsuccessful: 

Accorording to this troubleshooting guide

Last answer 10 December 2018 Last comment 10 December 2018
0   0 2
157

views

0

rating

Hello,

I have a question about creating properties with curl.

I already did create properties in Java with the following command.

<DO db.%CreateProperty("TotalSteps","%Integer","$.TotalSteps")>

It created the property TotalSteps with the type %Integer and the data path $.TotalSteps (since the header of my data source is also TotalSteps).

Now I would like to create the same property in curl with the following command

Last answer 4 October 2018 Last comment 4 October 2018
0   0 0
115

views

0

rating

Hi All,

I'm practicing Atelier in Eclipse, but

While working CSP page.

      1. Create new Web Application 

      2.  Open CSP Web Application in Atelier Project 

      3. New CSP page -> Save

i'm getting below error Message.  

/testv1/test.csp was saved locally but could not be saved remotely.

ERROR #5912: Page '/testv1/test.csp' does not exist

test.csp is saved locally but could not be saved remotely.

Last answer 14 September 2018 Last comment 15 September 2018
+ 1   0 3
159

views

+ 1

rating

Hi

I'm starting work with the Atelier. 

Starting from the point that Eclipse uses local files on the workstation, COS development can be versioned with market tools (For example GIT or Subversion).

I would like to know how the community has worked with code versioning, to create a consistent versioning model.

I initially have the following doubts:

Last answer 13 September 2018
+ 5   0 2
0

comments

234

views

+ 5

rating

I am having trouble configuring the environment in eclipse have download eclipse  for java script and web developers  followed the video but could not connect to the server I have my Apache server 7.0 added to the java environment and I can start and stop the server through eclipse IDE but when I fire atelier and add server I get the above error any help please .This is the first time I am trying to use the plug in through eclipse .Just in case There is another installation I need to do please advice but I am guessing something to do with atelier not seeing my configurations or permissions

Last answer 10 August 2018 Last comment 13 August 2018
+ 1   0 4
161

views

+ 1

rating

Hello,every body. 

I am having a problem when using atelier. I found that the web front-end related files (such as csp, css, js, etc.) will change in format when they are synced to the server.

For example:

The original format of the js file may be UTF-8. However, when I edited and saved in atelier, the file version format on the server became ANSI. I tried to configure the environment in eclipse, but it doesn't seem to work.

E.g:

Last answer 7 August 2018 Last comment 8 August 2018
+ 1   2 2
180

views

+ 1

rating

When trying to do an Atelier search, the scope section shows a little red 'X' next to the server dropdown box. Hovering over it shows a message stating that "the server does not support Atelier search."

What version of Cache is needed to allow for Atelier searching?

Last answer 9 July 2018 Last comment 9 July 2018
0   0 3
96

views

0

rating

Hi,

When i try to configure my server connection in Atelier (Eclipse), i am getting the below exception.

java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

It was all working fine and i think that the only thing which i have done was installing some windows updates. Now when i try to configure the server configuration i started getting the above error, any suggestions to fix this?

Thanks,

Last answer 10 June 2018 Last comment 5 July 2018
0   1 2
215

views

0

rating

When I delete a class package, it seems to delete it from my workspace but the delete action is not synchronized with the server. Is there a way to delete this package both locally and on the connected server within Atelier?

#UPDATE - Added product version information
Atelier version: 1.2.118 (Beta)
Caché $ZV: Cache for UNIX (IBM AIX for System Power System-64) 2017.2 (Build 744) Fri Sep 29 2017 11:04:53 EDT

Last answer 22 June 2018 Last comment 22 June 2018
0   0 3
161

views

0

rating

In Studio, you can open the inspector and view the SQL Storage Map on %Persistent classes. Can you do this in Atelier or do you have to read the XML text? If it doesn't currently exist, are there plans to include it? The inability to perform certain functions in Atelier that can be done in Studio can be a 'point of conflict' when asking/forcing/encouraging developers to move to Atelier.

Last answer 19 June 2018
+ 1   0 3
0

comments

156

views

+ 1

rating

As part of our security standards, we can't have our applications saving our credentials. For Atelier, this means our server connections. Is there a way to stop this by saving the connection parameters, but prompting for credentials on each run? Or is there another way?

Thank you

Last answer 19 June 2018 Last comment 18 June 2018
+ 2   0 3
340

views

+ 2

rating

Hello,

I need to access the value of a setting I created (ex: name_BO) within the logic of my BP.

Property name_BO As %String(MAXLEN = "");

/// Additional Settings 
Parameter SETTINGS = "name_BO:Basic:selector?context={Ens.ContextSearch/ProductionItems?targets=1&productionName=@productionId}";

But the class is common and the production item names will change.

Last answer 18 June 2018
0   0 2
0

comments

160

views

0

rating

I'm just getting started with Atelier and HealthShare. I created a persistent class, then realized I didn't want it. There is information in help about resetting storage definitions, where you use 'delete' in Studio. I tried that in Atelier. It deleted the class but not the storage. I can't delete the table directly because I didn't set it to allow DDL. This was done in a development environment and there is no data in the table. So, two questions:

Last answer 6 June 2018
0   0 2
0

comments

132

views

0

rating