Discussion
· Mar 3, 2016
Anyone using Visual Studio Code?

Is anyone in the fine community of developers who work with ISC technologies looking at Microsoft's Visual Studio Code offering?

One of Bill McCormick's recent posts about Atelier referred to Visual Studio being considered the best IDE. Granted, Code is far less of a tool than VS, and probably always will be. But it claims to be open source and cross-platform, i.e. Linux and OS X as well as Windows.

8 26
3 5.1K
Article
· Dec 4, 2015 3m read
Atelier Beta Cloud Infrastructure

A few people wrote to me asking about the infrastructure behind the Atelier Server implementation. Its neat and a worthwhile story to share so I am writing it up here as a post on the community. I want to go in to a little detail on why it was needed and then I will outline in detail how we went about implementing this.

10 24
0 1K
Article
· Jun 6, 2017 2m read
Atelier 1.1 Roadmap

It's been 6 months since InterSystems released Atelier 1.0 and we continue to roll out enhancements and new features through the beta channel (please see the Atelier Download page for details). In the meantime, we have received a lot of messages from the Developer Community with ideas for further improvements. Based on your feedback, we created a roadmap for Atelier 1.1 so you can conveniently track when specific features are going to be integrated.

7 15
0 1.4K

I have Caché/HealthShare installed in a local Ubuntu 16.04 LTS virtual machine. I've also installed Apache 2.4 from the apache2 bundle, and enabled SSL. I've configured Caché such that SSL/TLS is enabled on the SuperServer port but not required.

1 14
0 846

Hi-

I have Atelier client installed on a Mac and every now and then it just stops working. Currently I am getting this error when I try to synchronize my workspace with the server.

Synchronization failed: [server is broken] java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

Is anyone else experiencing similar problems and if so, what is the work around?

0 13
0 679
Article
· Dec 7, 2015 4m read
Source Control Hooks and Atelier

So another topic that has been of interest to a number of people since the beta was put up last week is in regard to Studio Hooks and Atelier. This requires a bit of background and then some discussion of how the architecture of Atelier necessitates some changes and then what our current thinking on the subject is.

3 12
0 1.2K
Question
· Jan 17, 2018
Atelier Dark theme

Hi

Has anyone managed to get a dark theme (Like Darcula or Obsidian) working on the Atelier plugin. The Eclipse themes apply to everything in the IDE except the editor window, so it kind of defeats the purpose. I've tried searching for one but so far no luck. I know you can set each colour individually in the settings but I'd like a single config I can load if possible.

Thanks

1 11
0 1.2K
Announcement
· Jun 15, 2018
Atelier 1.2 Stable Release

The Atelier 1.2 stable release update site (https://atelier.artifactoryonline.com/atelier/updates/stable/1.2/) has been updated to 1.2.119. This build contains all of the new features and enhancements the 1.2.118 beta build has as well as a number of bug fixes. Additionally, we have documented a list of the top time-saving keyboard shortcuts to help you become more productive. Give Atelier 1.2 a try and let us know what you think! Some of the key highlights include:

7 9
0 843
Question
· Sep 14, 2017
Conflict Resolution Wizard

Hi

When trying to sync a class to the server where the server class has been updated by another user, I, as expected, get the Conflict Resolution Wizard.

I can then use the wizard to copy code from the server side to my local copy using the arrows also as expected.

But when I have integrated the remote code into what I think is my local copy how do I save it so that it gets integrated into my local copy and synchronised to the server.

0 9
0 525
Question
· Mar 31, 2017
Atelier BPL editor

Is there a way to graphically edit BPL processes, or do we still need to use Studio for doing that?

Looking at the documentation, it appear there should be an Atelier BPL editor option available under Open With, but all I have is Atelier Class, HTML, INT, and MAC editors.

There is a BPL editor in the list, but it throws a "Bad editor input" error when trying to open the class file.

0 9
1 1.1K

My comments here relate to Atelier 1.0.137 on Windows connecting to Ensemble 2016.2 FT build 627.

I've been looking at what the Atelier Explorer view (hereafter AE), whose root elements are projects, lets us do with the contents of the namespace that the project is connected to:

1 9
0 878

To simplify the upgrade processes and to keep up with industry standards, we decided to make Atelier only available as an Eclipse plugin. Those of you who are currently using a standalone Atelier client will not be able to upgrade to a later version.

Please go to the Atelier Download page or see the sections below for the detailed instructions about installing Eclipse and the Atelier plugin. Feel free to reach out to support or leave a comment down below if you have any questions.

5 9
0 1.6K

I installed Atelier on Windows in order to take a look at how the BPL and DTL graphical editors accessible via the "Open diagram editor" action work. The diagram editor is opened but I get the following error:


Message from webpage
---------------------------
Unable to load SVG diagram. Please ensure your browser is supported for portal access.


It looks like Atelier uses IE in order to display the editor even though my Windows default browser is Chrome.

1 8
0 584

Hello,every body.

I am having a problem when using atelier. I found that the web front-end related files (such as csp, css, js, etc.) will change in format when they are synced to the server.

For example:

The original format of the js file may be UTF-8. However, when I edited and saved in atelier, the file version format on the server became ANSI. I tried to configure the environment in eclipse, but it doesn't seem to work.

E.g:

1 8
2 358