Atelier and Angular JS

Does anybody have already installed some Angular JS eclipse plugin on Atelier? Can you provide some tips about how to get it working?

Thanks.

 

  • + 1
  • 0
  • 482
  • 4
  • 7

Answers

Hi Fabio,

I haven't installed any Angular JS Eclipse plugin on Atelier yet. Could you let me know which plugin you have installed and what exact problem you have encountered so I can look into it?

Best,

Joyce

Hi Jue,

I am trying to install AngularJS from http://oss.opensagres.fr/angularjs-eclipse/1.1.0/. I don´t really know if this is the right one if it suits on our Atleier version. However I have searched for some Angular JS pluging on Google and followed the instructions. I am trying to install from Atelier->Help->Install New

This is the error that I am facing out:

Cannot complete the install because of a conflicting dependency.
  Software being installed: AngularJS Eclipse 1.1.0.201511091212 (angularjs-eclipse-feature.feature.group 1.1.0.201511091212)
  Software currently installed: Eclipse Platform 4.5.2.v20160212-1500 (org.eclipse.platform.feature.group 4.5.2.v20160212-1500)
  Only one of the following can be installed at once: 
    International Components for Unicode for Java (ICU4J) 54.1.1.v201501272100 (com.ibm.icu 54.1.1.v201501272100)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
  Cannot satisfy dependency:
    From: AngularJS Eclipse 1.1.0.201511091212 (angularjs-eclipse-feature.feature.group 1.1.0.201511091212)
    To: org.eclipse.angularjs.core [1.1.0.201511091212]
  Cannot satisfy dependency:
    From: Eclipse AngularJS Core 1.1.0.201511091212 (org.eclipse.angularjs.core 1.1.0.201511091212)
    To: bundle org.eclipse.wst.validation 0.0.0
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.4.1.v20160212-1350 (org.eclipse.e4.rcp.feature.group 1.4.1.v20160212-1350)
    To: com.ibm.icu [54.1.1.v201501272100]
  Cannot satisfy dependency:
    From: Java EMF Model Utilities 2.0.200.v200905140200 (org.eclipse.jem.util 2.0.200.v200905140200)
    To: bundle com.ibm.icu [3.8.1.1,4.1.0)
  Cannot satisfy dependency:
    From: Java EMF Model Utilities 2.0.201.v201001252130 (org.eclipse.jem.util 2.0.201.v201001252130)
    To: bundle com.ibm.icu [3.8.1.1,4.1.0)
  Cannot satisfy dependency:
    From: Eclipse Platform 4.5.2.v20160212-1500 (org.eclipse.platform.feature.group 4.5.2.v20160212-1500)
    To: org.eclipse.rcp.feature.group [4.5.2.v20160212-1500]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.5.2.v20160212-1500 (org.eclipse.rcp.feature.group 4.5.2.v20160212-1500)
    To: org.eclipse.e4.rcp.feature.group [1.4.1.v20160212-1350]
  Cannot satisfy dependency:
    From: Common Frameworks 1.1.300.v200904160730 (org.eclipse.wst.common.frameworks 1.1.300.v200904160730)
    To: bundle org.eclipse.jem.util [2.0.100,3.0.0)
  Cannot satisfy dependency:
    From: Validation Framework 1.2.102.v200905201610 (org.eclipse.wst.validation 1.2.102.v200905201610)
    To: bundle org.eclipse.wst.common.frameworks [1.1.200,2.0.0)
  Cannot satisfy dependency:
    From: Validation Framework 1.2.104.v200911120201 (org.eclipse.wst.validation 1.2.104.v200911120201)
    To: bundle org.eclipse.wst.common.frameworks [1.1.200,2.0.0)

 

It takes a while longer trying to compute 15 alternative solutions by itself and then pops up the error message above.

 Thanks.

 

 

Hi Fabio,

I just installed the AngularJS plug-in you mentioned successfully on Atelier 1.0.145. Can you get the latest Atelier and try it again?

Best,

Joyce

Hi Joyce,

It worked well on this version. Thank you very much!

Best Regards.

Fábio

What about Java? Does it also need a plug-in? Since Eclipse started as a Java IDE I would expect that Atelier should be able to handle Java projects/files without further configuration. Is this true?

Eclipse did not start as a Java IDE.  Eclipse had plug-in support from the beginning.  Java may have been one of the first languages supported, but Eclipse supports a variety of languages, including those, for instance, for Web development.

To install Java support, you need to do the following:

Help/install new software  

Click on available software sites

Put in the "Work with:" box http://download.eclipse.org/eclipse/updates/4.5.

Atelier uses the Mars platform.

From the check list pick what you want, but be sure for Java Development to click the check box - Java Development tools.

You'll also want to add http://download.eclipse.org/eclipse/updates/4.5.  There is an add button on your right.

Good luck!

Jonathan Levinson

Eclipse did not start as a Java IDE.  Eclipse had plug-in support from the beginning.  Java may have been one of the first languages supported, but Eclipse supports a variety of languages, including those, for instance, for Web development.

To install Java support, you need to do the following:

Help/install new software  

Click on available software sites

Put in the "Work with:" box http://download.eclipse.org/eclipse/updates/4.5.

Atelier uses the Mars platform.

From the check list pick what you want, but be sure for Java Development to click the check box - Java Development tools.

You'll also want to add http://download.eclipse.org/eclipse/updates/4.5.  There is an add button on your right.

Good luck!

Jonathan Levinson

Thanks, Jonathan. It was quick and easy. I have Java support now installed.

I think it would be helpful to have an item like "Working with other programming languages" in the Atelier User Guide with a short description as the one you provided and the link to the appropriate plug-ins.

José

 

Thanks for the suggestion.  I've posted an issue for documentation.