Atelier and External Web Server

I have Caché/HealthShare installed in a local Ubuntu 16.04 LTS virtual machine. I've also installed Apache 2.4 from the apache2 bundle, and enabled SSL. I've configured Caché such that SSL/TLS is enabled on the SuperServer port but not required.

I had originally set up port 80 and the default site to redirect to SSL, then realized that Atelier doesn't (yet) support an SSL connection. So I created a second, non-SSL site on a different port that allows me to log into the management console without SSL either locally or from another VM (or the host operating system). However, when I configure that port number in Atelier, it complains "Not Found. Check the web server configurations."

I've tried reconfiguring port 80 such that it doesn't redirect to the SSL port, but get the same results (interestingly, with the redirect in place I get "Found" in red when I test the port, but Atelier won't actually connect).

The next step is to re-enable the "private" web server and see if that works. But I'm hoping that Atelier will work with the external server too.

  • + 1
  • 0
  • 488
  • 5
  • 8

Answers

Very simple way to check is everything configured well. Just open this url in any browser.

http://localhost:[port]/api/atelier/

It should return some JSON

If it does not work, you should look at Apache configuration.

Can you put here your apache config file?

Hi,
ssl/tls (https) support for the atelier connections is planned for Atelier 1.1

It should work via external webserver too.

Did you get a response from http://<webserverip>:<port>/api/atelier/ in browser? (or postman, arc, etc.)

What version of Caché/HS you are running on server? (> write $ZV)

HTH,
Bernd

I'm getting a "Not Found" error.

$ZV = Cache for UNIX (Ubuntu Server LTS for x86-64) 2017.1 (Build 792U) Mon Mar 20 2017 19:22:31 EDT

Here's my apache2.conf:

# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.4/ for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#    /etc/apache2/
#    |-- apache2.conf
#    |    `--  ports.conf
#    |-- mods-enabled
#    |    |-- *.load
#    |    `-- *.conf
#    |-- conf-enabled
#    |    `-- *.conf
#     `-- sites-enabled
#         `-- *.conf
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
#
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.
# Global configuration
#
ServerName oobuntoo.local
#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at &lt;URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex&gt;);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"
#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
Mutex file:${APACHE_LOCK_DIR} default
#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}
#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300
#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On
#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100
#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5
# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off
# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a &lt;VirtualHost&gt;
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a &lt;VirtualHost&gt;
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log
#
# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
#
LogLevel warn 
# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
# Include list of ports to listen on
Include ports.conf
HostNameLookups off
# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
&lt;Directory /&gt;
    Options MultiViews FollowSymLinks
    AllowOverride None
    Require all granted
    &lt;FilesMatch "\.(log|ini|pid|exe|so)$"&gt;
            Require all denied
    &lt;/FilesMatch&gt;
&lt;/Directory&gt;
&lt;Directory /usr/share&gt;
    AllowOverride None
    Require all granted
&lt;/Directory&gt;
&lt;Directory /var/www/&gt;
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
&lt;/Directory&gt;
#&lt;Directory /srv/&gt;
#    Options Indexes FollowSymLinks
#    AllowOverride None
#    Require all granted
#&lt;/Directory&gt;
# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess
#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
&lt;FilesMatch "^\.ht"&gt;
    Require all denied
&lt;/FilesMatch&gt;
#
# The following directives define some format nicknames for use with
# a CustomLog directive.
#
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
#
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
#
LogFormat "%v:%p %h %l %u %t "%r" %&gt;s %O "%{Referer}i" "%{User-Agent}i"" vhost_combined
LogFormat "%h %l %u %t "%r" %&gt;s %O "%{Referer}i" "%{User-Agent}i"" combined
LogFormat "%h %l %u %t "%r" %&gt;s %O" common
LogFormat "%{Referer}i -&gt; %U" referer
LogFormat "%{User-agent}i" agent
# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.
# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf
# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
#### BEGIN-ApacheCSP-SECTION ####
LoadModule csp_module_sa "/apps/isc/cspgateway/bin/CSPa24.so"
LoadModule cspsys_module_sa "/apps/isc/cspgateway/bin/CSPa24Sys.so"
CSPModulePath "/apps/isc/cspgateway/bin/"
Alias /csp/ "/apps/isc/hs/csp/"
&lt;Location "/"&gt;
    CSP On
    SetHandler csp-handler-sa
&lt;/Location&gt;
&lt;location "/hs/csp"&gt;
    SetHandler csp-handler-sa
&lt;/Location&gt;
&lt;Location "/csp/bin/Systems/"&gt;
    SetHandler cspsys-handler-sa
&lt;/Location&gt;
&lt;Location "/csp/bin/RunTime/"&gt;
    SetHandler csp-handler-sa
&lt;/Location&gt;
CSPFileTypes csp cls zen cxw
&lt;Directory "/apps/isc/hs/csp"&gt;
    AllowOverride None
    Options MultiViews FollowSymLinks ExecCGI
    Require all granted
    &lt;FilesMatch "\.(log|ini|pid|exe)$"&gt;
        Require all denied
    &lt;/FilesMatch&gt;
&lt;/Directory&gt;
&lt;Directory "/apps/isc/cspgateway/bin/"&gt;
    AllowOverride None
    Options None
    Require all granted
    &lt;FilesMatch "\.(log|ini|pid|exe)$"&gt;
         Require all denied
    &lt;/FilesMatch&gt;
&lt;/Directory&gt;
#### END-ApacheCSP-SECTION ####
#### BEGIN-ApacheCSP-SECTION-HS ####
Alias /hs/csp/ "/apps/isc/hs/csp/"
#### END-ApacheCSP-SECTION-HS ####

ok, thanks for providing the conf.

Do you have configured the cspgateway to route / or /api app-path to approperiate server?

See CSP-Gateway-Management of external webserver : http://localhost/csp/bin/systems/Module.cxw

HTH,
Bernd

I had only one entry in CSP.ini, for LOCAL. The server name was configured appropriately, and the '/' app path was routed to it. I don't have an explicit path to '/api' but there wasn't one in the "private" web server's CSP.ini either and that works fine for Atelier.

Hi Jeffrey,

it seems this is a specific configuration issue which needs a more deeper look. (further logging, etc.)

I would suggest you to contact WRC support so that we can continue investigation.

Thanks and Regards,
Bernd

Hi Jeffrey.

Please check web-application settings (Management portal -> System Administration -> Security -> Applications -> Web Applications) and ensure that application '/api/atelier' is Enabled -- it has "Application" checkbox checked in Enabled section.

Hope this might help,
Alexander.

since via the private webserver it is working i don't think this (/api/atelier = disabled) is causing the issue.

So, I got it working.

It took a long time, because I missed one very important detail: the trailing backslash on the URL is very, very important. I was testing in my browser with http://oobuntoo.local:8881/api/atelier, which isn't exactly what Bernd and Dmitry told me to do. Since that wasn't working, I wasn't bothering to test Atelier's ability to connect. So somewhere in my flailing around I managed to fix whatever was preventing it from working, and now I need to backtrack through that and figure out what it was.

So ... thanks everyone. I'll mark the right answer as correct as soon as I figure out which one it was!

this is great news, Jeffrey. I am glad you got it working.

Yes, this is rest api, the trailing slash in url IS important :)

Bernd

I've backed out all of the changes that I would have suspected might have an impact, and it's still working (and yes, I've restarted both Apache and Caché). The only thing I haven't yet backed out was the creation of a non-SSL site  on port 8881, but that's something I did early on and am fairly certain I tried an Atelier connection after. But I may be misremembering ...