Management Portal

Syndicate content 17 

Hello,

When i click on the menu to  run the  Data import wizard  from MP, i receive following CSP error

<UNDEFINED>zOnPageHEAD+229^%cspapp.exp.utilsqleximwizardcontent.1 *schemaname : CSP Error

 

It is happening for all the namespaces. Looks like some permission issue.  Same issue with Data Export wizard. Help to resolve this will be appreciated.

I am using

Cache for Windows (x86-64) 2017.2.2 (Build 865_0_18763U)

Thanks,

Jimmy Christian.

Last answer 28 June 2019 Last comment 12 April 2019
0   0 2
64

views

0

rating

Hi all, 

I am trying to create multiple tasks all in a single task. 

 

For instance MyApp has three tasks.

One to send a email if a limit is exceeded = MyApp-check-credits

One to purge files = MyApp-purge

One to auto delete files = MyApp-Del 

 

I would love to get all tasks MyApp-check-credits, MyApp-purge, MyApp-Del into a single parent task called MyApp-AllTasks.

 

Is there anyone that could give me guidance of how to complete this it would be much appreciated. 

Last answer 27 May 2019 Last comment 30 May 2019
0   0 3
119

views

0

rating

So i'm having this problem with the task manager, the tasks simply stopped running. I had a problem with queued massages and trying to figure out what to do i'm afraid I may messed up something else, can someone help me ?

Last answer 9 May 2019 Last comment 28 March 2019
0   0 3
100

views

0

rating

I have an above error when purging record map batches and was wondering if anyone  out there has ever experienced this and if they have please any advice

Failed to purge body for header 9747192, BodyClassname='******.Batch':ERROR #5823: Cannot delete object, referenced by '*****.Record.%ParentBatch'
Last comment 18 April 2019
0   0 1
0

answers

39

views

0

rating

On one of our servers, when I am in Mgmt Portal and click the link for Configure / CSP Gateway Management, I get this url:

http://ipaddress.of.server:port/INSTANCENAME/csp/bin/Systems/Module.cxw?CSPSYS=0&CSPSYSreferer=_CSP.Portal.Home.zen

but the page displays a 0, and nothing else. Literally, just a 0.  This link works on our other servers, with the same URL.  Any idea why? 

 

Thanks,

Laura

Last answer 4 April 2019 Last comment 4 April 2019
0   0 1
62

views

0

rating

Hope someone can help me,  so i was developing a script and during the tests I was using the csession to execute a method. Also i thought i had to stop the instance i was using, so I used the ccontrol stop [instanceName] to stop the instance, but when i restarted the instance i got this error trying to start my production, I have an idea of what's the problem but i don't know how to fix it.

Last answer 29 March 2019 Last comment 29 March 2019
0   0 3
79

views

0

rating

I'm able to log into my local instance of HealthShare through the Management Portal, but once I've done so, the screen is entirely blank. I'm still able to access Terminal and Studio without any issue, as well as a hosted instance's Management Portal. I've tried stopping and starting HealthShare, no luck. I've been working on this instance for the past several months and haven't experienced anything like this, and I don't know of anything that I was doing that would have broken the Management Portal. Anyone have a suggestion as to where to go from here?

Last answer 11 March 2019 Last comment 6 February 2019
0   0 2
124

views

0

rating

Can I apply a custom resource to a Management Portal page through code, using the method or global? The documentation only shows the manual mode: https://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY=GCAS_rsrcs#GCAS_C181701

Or export the settings already saved.

Last answer 7 March 2019 Last comment 8 March 2019
0   0 2
75

views

0

rating

Hi,

I have a custom classes that that I use with EnsLib.SQL.OutboundAdapter to convert HL7v2 messages to SQL INSERT statements to write results to an SQL database.

Weirdly the management portal is not drawing the the lines between my process and operation when viewing my production on the ' Ensemble > Production Configuration' screen.  Clicking the green dot flashes the 'computing connections' message, and highlights my operation, but no lines get rendered: 

Last answer 4 February 2019 Last comment 1 March 2019
0   0 3
132

views

0

rating

Our PAS system supplies date in a particular date format (ISO 8601 compliant) that includes seconds and milliseconds.  Because many downstream systems cannot handle milliseconds (and some don't even want seconds) many transformations are required to truncate the data.

Last answer 18 February 2019 Last comment 18 February 2019
0   0 2
87

views

0

rating

Time after time on CSP Session page of our Cache 2017.2.1 installation I see that all licenses are consumed by CSP sessions of /csp/sys, /csp/sys/op/and /csp/sys/mgr applications which I assume are sessions of Management Portal. The problem is that there are only few of us accessing the Portal and as we test by browsing Portal, we can't reproduce the problem. 

Is there any way to see client IP of CSP session? Any other way to approach the problem?

The problem looks very similar to the Forefox-related one but we don't use Forefox.

Last answer 12 June 2018 Last comment 13 June 2018
0   0 3
186

views

0

rating

I have a cache client with a list of several servers.

One of the server is working with an IIS server that is not the Cache DB server.

The connection to the IIS server is only through https (SSL)

I tried to define the Web Server IP Address to https://some.server.name but it didn't let me to specify the https

So I tried to define Web Server Port to 443 but when I chose the SMP it's trying to open http://some.server.name:443/csp/sys/UtilHome.csp

Last answer 17 January 2018 Last comment 8 June 2018
+ 1   0 5
362

views

+ 1

rating

Hi! I have a local project written on Cache and Atelier on my PC. I need to move it to notebook. Tried to export globals, classes, MAC-programms and csp with frontend stuff, but after I created my apps on notebook and imported my set, it just didn't work. I think it's because I have some settings on Management Portal, so how can I export portal settings and what I should export to have my working apps on another computer?

Last answer 29 April 2018 Last comment 29 April 2018
0   0 2
131

views

0

rating

Good day,

Is there a way to change the theme in management portal? or at least the color of the header.

Issue is, some users have access to Development and Testing and Production environments. I would like a way to color-differentiate the environments to reduce the errors. 

Last answer 26 April 2018 Last comment 26 April 2018
0   0 3
217

views

0

rating

Hello Community,

I recently encountered a issue with Caché and I can't figure out where the problem is coming from.

I noticed that the license limit (200)  was reached whenever I was opening my Studio (so it seems). When this occurs, I restart Caché (with the Cube in the Taskbar), and the number of license used is back to 1%, but grows back after.  The time taken before the number of license  grows back again looks pretty random.

Here is a couple of screenshots :

Last answer 13 December 2017 Last comment 21 November 2017
0   0 3
768

views

0

rating

Hi all, This is a bit embarrassing, and not that critical.  I have a local instance of Caché 2016 on my computer, for playing around with.  I was attempting to set up two-factor authentication on this instance, and I thought I simply disabled all users except for my own user and enabled two-factor for this user.  The next time I tried to login to the Management portal, I received a Server Availability Error:

http://localhost:57772/csp/sys/UtilHome.csp

Last answer 3 March 2017 Last comment 9 November 2017
0   0 0
1103

views

0

rating

Recently, we scheduled two tasks (1008 and 1009) within Task Manager. Task ID 1008 is set to run after Purge Tasks (%SYS-ID:3), and Task 1009 is set to run at 7:00:00 each day.

In attempt to provide as much detail as possible, each of the tasks are as follows:

  • Task 1008

    WHILE (($p($h,",",2) < $ZTH("10:00 PM")) && ($P($g(^Task.1008(+$h,$j)),"^",1) = +$h)) { J ^ROUTINE, ^ROUTINE2 D SUB^ROUTINE3 H 5 }

Last answer 26 September 2017 Last comment 11 October 2017
0   0 3
237

views

0

rating

Hi there.

I was wondering if there was a supported way of editing the Title bar of the management portal so that at a glance it is clear as to what environment is being worked on. This would be in addition to the namespace and server name being displayed.

Ideally I would like to make it clear at a glance that a user is working within the Dev or Live environment.

Last answer 29 September 2017 Last comment 29 September 2017
0   0 1
165

views

0

rating

Currently, we are utilizing batch jobs at the OS level to kick off routines that watch for files. We are trying to convert these processes to be performed by the Task Manager.

The routines have while loops and perform while loops so long as the time parameters are being met.

What's the best way to ensure Task Manager kicks them off after the completion of the shutdown/backup/start process is performed, which we do nightly? I want to ensure that it starts it regardless of the time that we've set.

Last answer 21 September 2017 Last comment 21 September 2017
0   0 3
377

views

0

rating

We have a large number of processes and operations being applied to outbound HL7 messages from our PAS.

If I select a message, and open its visual trace, I see the service, as well as all processes, and operations. 

My debugging is often about a new operation, and I don't need to see all the other operations that are in functioning as desired.

Last answer 20 September 2017 Last comment 20 September 2017
0   0 1
189

views

0

rating

My boss would like to change the Ensemble logo that one sees in the mangement portal, because it's part of the DeepSee Anaylzer.  

 

I can see where it lives on the generated html.  

I kow that you can set the logo for the User POrtal settings in DeepSee -- you can specifiy a URL for your logo.  But we'd like to go one stee further and change the Ensemble by InterSystems to our own logo / company name.  

Is it possible to change this in the code?  Is there a Configuration setting to change this?

Thanks,

Laura

Last answer 2 August 2017 Last comment 2 August 2017
0   0 1
268

views

0

rating

Hello mates,

When turning on the “Archive IO” option within the business operations, it provides us the capability of seeing the input and output communication with external systems. For instance, watching the messages sent out + ACK message sent back .

Our production has got a scheduled task that runs daily (by default I guess, as many others) and is in charge of purging “Errors and log files”. And this is likely to be linked to the “Archive IO” feature, right?

Last comment 17 July 2017
0   0 3
0

answers

175

views

0

rating

Recently I was conducting a remote support session with a site. The desktop they were sharing with me was on a PC configured with German as the native language. Since my German is rather rusty, and virtually non-existent when it comes to computing terms, I was glad to be able to switch the Portal session into English.

This is done from the page that appears when you use the About link:

+ 2   0 1
0

comments

168

views

+ 2

rating

I know the process ID< and I know the global name: ^||testing(index).  From the terminal (and therefore, and different process ID), how do I view the contents of ^||testing() ?  Not the list of process private globals; the contents of this single PPG.

Thanks,

Laura

Last answer 12 June 2017 Last comment 12 June 2017
0   0 3
387

views

0

rating

Hi, Community!

If you need to help maintain and monitor your system, you could give additional users access to the Management Portal.
Are you interested?
So, check the new Developer Video of the week:

Webinar: Securing the Management Portal

 

0   0 2
0

comments

123

views

0

rating