InterSystems Developer Community is a community of 16,925 amazing developers
We're a place where InterSystems IRIS programmers learn and share, stay up-to-date, grow together and have fun!

Hello Everyone,

I have a healthshare web application with production, I try to make a field in basic setting of business service, and I would like to set a string to DISPLAYLIST and VALUELIST of that Property (string maked by query to sql table). I code the same here but it's syntax incorrect in DISPLAYLIST = GetTypeDisplay(), VALUELIST = GetTypeValue(). Someone know a best way to solved my problem? Thanks so much!

0 8
0 1.4K

Hello Everyone,

I was wondering about the best way to initialize several variables, or several lists of variables.

Would it be better to write it like:

set (var1, var2, var3) = "value1"
set (var4, var5) = "value2"
set (var6,var7,var8) = "value3"

or

set var1="value1", var2="value1", var3="value1", var4="value2", var5="value2", var6="value3", var7="value3", var8="value3"

or

0 6
0 427

We are running old VB code on a Windows 2012 R2 server.

In the last month the following error has been happening.

Failure to create CacheObjectConnection.
Failure in GetClassInfo for CacheObjectConnection

Factory not connected to server
Send to Cache' failed

Neither the the code or Cache instance has not changed.

Cache 2017.1.1.111.0

The code:

Dim bRtn As Boolean
Dim objCacheObject As Object
cntr = 1

0 7
0 843

Hello. I'm wondering if anyone has experienced a similar error and if so, if they can point me in the right direction. I have a client who is logging into Epic and is using the Epic SAML to single sign on to our HealthShare system. We saw that it authenticated her through (from Epic to HealthShare) but when it attempted to open up the patient, we received the following Java error. When she clicks OK, it keeps coming back. Also, she is accessing Epic through a Citrix connection (if that helps with anything). Here is the error below.

Thanks!

0 1
0 695

The source class of a DeepSee cube has a property referencing a different class:

Class ClassA Extends %Persistent {
     Property P1 As ClassB;
}

When records in class B change, the ^OBJ.DSTIME global for Class A will not be automatically updated. This means that synchronization of cubes based on source class A will not reflect the changes occurred to property P1.
This post will help you determine the best way to achieve synchronization of properties referencing a different class

4 2
2 421

Hi All,

Who, in the age of digital transformation, doesn't want to reap more benefits out of any process, procedure, and resource we have? At InterSystems Solution Developers Conference (part of InterSystems Global Summit 2018) we will have sessions on how to improve the way applications are built with modern tools like Docker containers, Gitlab, Circle CI, Travis, etc., how continuous integration and continuous delivery (CI/CD) processes can help us deliver more value quickly to the end-user, and how we can start thinking about modernizing traditional applications.

4 0
1 399

Hi Community!

Please welcome a new video on InterSystems Developers YouTube:

Deploying Shards Using the API

https://www.youtube.com/embed/pPuWoa_KD7A
[This is an embedded link, but you cannot view embedded content directly on the site because you have declined the cookies necessary to access it. To view embedded content, you would need to accept all cookies in your Cookies Settings]

0 0
0 322

Hi -

I need an example of what I need to "map" to have a common dashboard defined so it will visible/usable in multiple namespaces.

I have created a dashboard in "SAMPLES" (namespace and database) and I would like to have this dashboard be accessable/useable from a 2nd namespace, but I'm not having any success in doing mappings (global/package/routine/data) to be able to get DeepSee to be able to see/display the dashboard.

What is the minimum that I need to map?

0 4
0 354

I have a csv record mapper that reads in a batch and my batch has a header and trailer that changes all the time but it is of fixed length so I override the Get Batch Header method from the simplebatch class to something like below but my problem is when the batch is read in It still tries to bring in another empty batch like the picture below any reason why that is here is my code.The red code is the changes made. After several trace logs it is being called twice first time with the batch [1] and[5]is the second call how can I stop that from happening

0 5
1 371
Question
· Aug 17, 2018
%VID Question

I'm Trying to create a "Windowing Function" In Cache similar to SQL Server. I'm trying to create a Row Number for every account number (Example Below). I know I can use the %Vid function to create the Row Number but I need the row number to reset with every new account number. In SQL Server it would be Row_Number over (Partition by account number order by account number). and Example of what I am trying to create is below.

Row Number Account Number

1 1

2 1

0 1
0 723

To deploy a DeepSee solution, the docs recommend that you define a namespace on the reporting (mirror) server, and "define mappings to access the application data, application code, DeepSee cube definitions, and DeepSee data on this server". (http://docs.intersystems.com/ens20152/csp/docbook/DocBook.UI.Page.cls?KEY=D2IMP_ch_overview#D2IMP_overview_architecture)

1 3
0 287

Hi,

we are moving an existing ZEN-Application to a new version of Caché (2017.2.2). It is a rather old application and we need to do some modifications due to the thightend security of ZEN in this and prior release (we came from 2013.1). One of the changes required is to alter a table Name of a ZEN-Table on the server-side. Anyway this gives us a problem, since we receive an error

ERROR #5001: Client modification of protected property ( tableName) disallowed for security reasons.
SOURCELEMENT: %ZEN.Component.tablePane (tpSimilarity)

0 2
0 406

We have a new requirement being push down by our Data Security to no longer use Local SQL Accounts to access our Databases. So they asked me to create a Service Account that is on the Domain for our connections to each database.

I tried just changing my JDBC connection to using this Service Account and Password but I am not having any luck trying to connect to the database.

" Connection failed.
Login failed for user 'osumc\CPD.Intr.Service'. ClientConnectionId:ade97239-c1c8-4ed1-8230-d274edb2e731 "

1 4
0 3.5K

Traditional Caché Objectscript has the multi-dimensional array as its main form of complex data structure and the $order command as the main means of traversing said data structures. But newer versions of Caché ObjectScript also have data structures that are direct parallels of what languages such as JavaScript provide, in the form of %DynamicObject and %DynamicArray. These have an easy to use iterator feature via the %GetIterator method, and even a handy built-in literal syntax for constructing new objects.

0 3
0 918
Question
· Jul 18, 2018
Market penetration

My understanding is that IRIS is a new technology and does not replace Cache or Ensemble and to that end is more of a modernization than a repackaging. Is that accurate?

Is IRIS and HealthShare heavily penetrated in the payer space of primarily dominate in the provider space? What is the trajectory for InterSystems to penetrate the payer landscape?

2 1
0 441

I have been tasked with setting up outage notifications to my group (for example, sending an email or automatically generating a problem incident when HealthShare/Ensemble experiences an outage), and determining outage statistics (for example, the time frame when HealthShare/Ensemble was unavailable). I admit I am having a hard time even defining what should be considered an “outage”.

0 1
0 271
Question
· Aug 10, 2018
using Microsoft diskspd

Hi,

Has anyone got any experience of using the Microsoft diskspd utility to test the storage infrastructure in Healthshare/Ensemble environment.

I am interested in getting some figures to highlight any issues with different approaches to provisioning the disks on our new environment.

I am at a loss as to what parameters I should use to give a reasonable synthetic load that will give me any indication of potential issues. Any pointers would be greatly appreciated!

Kind Regards,

Jason

0 3
0 310
Question
· Aug 2, 2018
Invalid precision value

Hi,

I'm trying to execute a function in a loop using studio but I'm having an error; "ODBC driver for sql server Invalid precision value"

Any help please?

Example :

for i=1:1:2{

...

0 1
0 479