Question
Mahmudul Hasan · May 31, 2020

Startup aborted on Mac OS Catalina

I am new on Mac. I have tried to install Caché on Mac. The installation completed successfully but it failed to start up. 

It shows following failure message on the terminal:

Starting up Cache...
Once this completes, users may access Cache
Starting SANCHOY
Using 'cache.cpf' configuration file

Starting Control Process
Automatically configuring buffers
Allocated 430MB shared memory: 256MB global buffers, 35MB routine buffers
Creating a WIJ file to hold 99 megabytes of data
chdir failure. errno=13, program /Users/hello/Documents/SanchoyCache/bin//./cache
Call InterSystems Technical Support. : Permission denied

Sign-on inhibited.
See cconsole.log for details.

You can point your browser to http://MacBooks-MBP:57772/csp/sys/UtilHome.csp
to access the management portal.

Installation completed successfully

Moreover, I couldn't access the Management  Portal.

 

I also tried the command,

ccontrol start <Instance Name>

It also shows ** Startup aborted ** messages

Starting SANCHOY
Using 'cache.cpf' configuration file

Now attempting WIJ compare, ./CACHE.WIJ

Cache Write Image File has blocks to be written, but it has an illegal format,
We failed to fully restore the WIJ. The recommended action is to
abort cstart, resolve the problem and try again. The other
option is you can delete the image journal and continue with cstart.
If you delete the image journal and continue you will probably have
database degradation in the databases that were not fully restored.

If you are not absolutely sure you want to do this, do not continue
if you change your mind, you can run cstart again and you will
be given this choice again.
Is an operator present to answer questions (Y/N)? Y => Y

Do you want to delete the Write Image File (Y/N)? N => N

A problem was encountered while attempting to restore the write image
journal file (CACHE.WIJ). See the console log for more information 
before attempting to start cache again.

** Startup aborted **

Recovery failure. Startup aborted.

Anyone can help me to solve my problems please?

0
1 402
Discussion (5)1
Log in or sign up to continue

I've been using macOS Catalina, and while I'm also using docker for any project I work with, I even did not notice that it's now not supported.

So, use docker, it's very easy.

I haven't install docker yet. But I'll definitely try with docker. Can you please provide me any guideline on how to install Caché with docker? Any kind of help would be appreciated. 

First of all, you should not think, that using docker is the same as you would install it natively. You have to build your own per-project environment with docker. 

Where to find information

In addition, you would need a code editor, and you can use cross-platform VSCode with extension VSCode-ObjectScript. Brief info about how to install and configure it on Learning.