[Atelier][CSP] Problem debugging CSP file with Atelier

Primary tabs

Hi everyone,

I have an existing application on HealthShare 2015 and decide to move it to HealthShare 2018 to make use of Atelier support. I am using Eclipse Photon with Atelier Plugin 1.3.

Most of things are working better on Atelier comparing with Built-in studio of HealthShare. However, when I tried debugging CSP file with Atelier I encounter 2 problems:

1. 

From a CSP file, I can open the generated *.INT file without any problem. But when I open the generated *.cls file it shows me the error:

2. In the built-in HealthShare studio, I can debug a CSP file by viewing other code, put the breakpoint in the generated corresponding CLS file. In Atelier it doesn't let me open the generated CLS file.

I've tried to put a breakpoint in generated INT file, the application indeed hit the breakpoint. However, it doesn't let me continue debugging on the INT file and also shows me the message: File cache2://HEALTHSHARE/MYNAMESPACE/csp.testcsp.cls not found

I've searched through Atelier document here https://cedocs.intersystems.com/atelier/latest/index.jsp?topic=%2Fcom.intersystems.atelier.help%2Fhtml%2Ftasks%2Fatelier-debug.html but didn't find any relevant information. Any help is appreciated.

Replies