I reached out to Gary Monger yesterday and asked him how he configured Apache for his SMART on FHIR demo?
See https://learning.intersystems.com/mod/page/view.php?id=2948.
Gary's response was for me to post my question on the Developer Community forum - so that other people can benefit from the answer.

This is what I asked Gary:

I'm after turning a local Health Share instance on my laptop into a SMART on FHIR server.

0 4
0 560
InterSystems Developer Community is a community of 14,062 amazing developers
We're a place where coders learn and share, stay up-to-date, grow together and have fun!
· Jan 19, 2018 3m read
DigitalOcean API implementation

Recently DigitalOcean introduced new plans for droplets, but as existing droplets stayed on the old plans I decided to use API to resize them automatically. After reading tutorial, I wrote partial client for DigitalOcean API, which I would like to share today.

3 0
1 376

I have an interface that does not send me specific ID's, so I am scanning the AIL3.2 (Text) field for certain characters. The Routing rule is getting pretty big with all the OR statements. Is there a way that I can define what I am searching for in the data lookup table, and not have to scan the whole field that it does by default? Is there a way that I can simplify this?

0 3
0 716
· Jan 16, 2018
Testing in studio

After creating a ClassMethod for a routing rule is it possible to test an HL7 message within Studio rather than using Management portal? It would make it easier to debug the custom function to see where the rule is failing.

0 2
0 307

We are trying to make an ODBC connection via our intersystems ensemble (2016.2 running on ubuntu). However, when I am testing the connection I receive a pop-up that: "Http object response incomplete or invalid.0,#R". Note that the iodbctrace.log remains empty (and it is working because on the first try it registered a 459 error that I should activate kerberos, which I did). Any advise where I should look?

I have taken the following actions:

1. Expand the cacheodbc.ini in the mgr directory as follows:

0 2
0 1,215

Hello, I am trying to get the Zen Print Server to work so that i can use the pdfprint mode in Zen Reports. Zen Reports will create pdfs just fine, so that part is working. And the printer works fine from other applications on this computer and I have verified the printer name a bunch of times.

This is Caché 2016.2 on Windows 10. I have tried this using Adobe 11.0 and Adobe DC. I have made and started a Zen Report Print Server with

Name = "ZenPrint"

Port = "4321"

and Ping Port = "4320"

0 4
0 214
· Jan 16, 2018
ECP Connectivity

Hi All,

Background: I have my data in Globals on a Cache instance A and I SQL projected(Added SQL Storage) all my globals as Classes to do SQL Operation.

I am about to start writing my application code in Ensemble(Planning to use Business Service, process and Operation) , Now I wanted to do ECP connection between Ensemble instance and Cache instance to get data from Cache.


How to do ECP connection between two instances?

Does SQL projection of classes is really required or I can use the globals from Cache server.

0 1
0 658
· Jan 15, 2018
using sql link table wizard

I'm trying to create an sal connections from one cache system to another. I've created the connection part and I think that is working. When trying to link a table through the link table wizard, I'm getting an error "<MAXSTRING>zCreateOneLinkTable+52^%CSP.UI.SQL.LinkWizardResultPage1.

Is this due to my global block size in the new system not being large enough? It is currently set at 8192.

Thank you


0 2
0 489
· Dec 13, 2017
SQL or Cache Function?

Hi -

I'm creating a custom report in Health Insight via SQL and one of the requirements says that I must include patients who are >= 13 years old (which is easy) but I also need to include patients who WILL be 13 years old as of December 31st of current year that the report is ran in.

I see that there is an Age column and an AgeInMonths column in HSAA.Patient. and of course a DOB column. I'm wondering if it is possible to do this purely using SQL (and SQL functions) or if I will have to incorporate a COS function to achieve this requirement.

Any suggestions?

0 12
0 1,212
· Jan 15, 2018
Headers in HttpRequest

Hi Guys,

I'm using Ensemble 2014 and have a code that Posts HttpRequest to a REST API and working fine, but don't know how to add Header to my request!?

I tried Set Request.SetHeader("Source","Civicview") but it's bringing a Syntax error, any help pls?

1 3
0 1,013

Last week saw the launch of the InterSystems IRIS Data Platform in sunny California.

For the engaging eXPerience Labs (XP-Labs) training sessions, my first customer and favourite department (Learning Services), was working hard assisting and supporting us all behind the scene.

11 3
0 936

In a Business Process using the %PrimaryRequestHeader I can call GetAdapterSettingValue and get the setting from a Business Service. But once I am in the Business Operation there is no class for %PrimaryRequestHeader. Is there another way to get setting in the Business Operation that was define in the Business Service ?​

0 3
0 380
· Aug 21, 2017
Zen Reports error


I'm having the following error visualizing a PDF report.

An invalid XML character (Unicode: 0x3) was found in the value of attribute "Reaction" and element is "Allergies".

Aug 18, 2017 10:50:29 AM org.apache.fop.apps.FopFactoryConfigurator configure

INFO: Default page-height set to: 11in

Aug 18, 2017 10:50:29 AM org.apache.fop.apps.FopFactoryConfigurator configure

INFO: Default page-width set to: 8.26in

Aug 18, 2017 10:50:30 AM org.apache.fop.cli.Main startFOP

SEVERE: Exception

0 3
0 375

Where did the RemoteSystemsTempFiles project come from?

If you're using Atelier, you may have noticed a project called "RemoteSystemsTempFiles" in the Atelier Explorer and Project Explorer views. This project is automatically created by the Eclipse Remote Systems Explorer (RSE) on start-up. The RSE allows you to connect to and work with a variety of remote systems.

You can either hide this project within your views, or remove it completely by following the steps below.

5 0
0 3,595

What happens if you don't declare a Persistent value when you call ExecuteQuery()? What does Ensemble set as the key value for your query? I have a query that I've executed on SQL Server, and I get 15 rows, but because this is my second time querying the data Ensemble thinks it exists.

The Method in question is SelectProviderClarityAudit. If I call this query multiple times it is not returning the same number of results each time in Ensemble.

0 3
0 398