InterSystems Developer Community is a community of 12,637 amazing developers
We're a place where coders learn and share, stay up-to-date, grow together and have fun!

Hi All,

I have a rasing task from BPL using <call>, it needs to add an entry in workflow task list and the task has to rais.

after performing,

I didn't see the entry in workflow task list, but the task gets raised.

In What is the root cause for this.

Why there is no entry in tasklist after raising task?, How to verify it?


0 1
0 230

I defined the variables in Cache, as follows:

Property Content As% Stream.GlobalCharacter [Required, SqlColumnNumber = 3, SqlFieldName = B_Content];

And then use the SQL statement to add:

insert into table_name (B_Content) values ('very long string');

But the error:

0 3
0 510
Nadirbek Nurlybekov · Oct 26, 2017
Content-Type in REST

Greetings to all!!! How to get the value of the Content-Type field from the object of the class %Stream.Object obtained with:

stream=% request.GetMimeData (FormDataName, 1) 

I tried:

0 2
0 358

I am designing the software architecture for an Ensemble/Healthshare production to be deployed on Amazon AWS EC2 servers (2 mirrored m4.large - 4 vCPUs / 16 GiB RAM running RedHat Linux 3.10.0-327.el7.x86_64 and Healthshare for RHEL 64-bit 2016.2.1). It's a rather CPU-intensive production involving massive XSLT 2.0 transformations (massive both in terms of size and volume). I was wondering if anyone has experience configuring Ensemble productions on EC2 servers. My question or concern has to do with the following statement in the Ensemble documentation:

0 2
0 705

Greetings to all!!! Suppose there is a table Mother (ID, Name) and Child (ID, Name, Mother), Mother in the table Childis a relationship. Let's say the task is to deduce the names of all the children whose their moms' names start with the letter 'A', I can do this in two ways in sql, and I can not understand the difference, the pros and cons that when to use:

0 1
0 346

Hi all,

For special definition of the company, we need to define a PoolSize according to the environment that the "Ensemble" is working.

So the first try as been add the parameter into "System Default Setting"

However, this parameter is not available in "Setting default values" in Setting tab.

I've opened the code of my production and I've noted that this parameter is a attribute of the XML element of this item

0 1
0 414

I have a batch record mapper that reads a csv file and passes the message to a process that uses the EnsLib.MsgRouter.RoutingEngine and would like to pass the message to an operation that will output that as a XML file but so far been unlucky as the operation that I use , uses the EnsLib.EDI.XML.Operation.FileOperation which only works with the messages("BusinessOperation class for writing XML messages to a file.

0 2
0 809

Hi all,

Is there a way to setup a classmethod or routine to execute immediately after cache is started?

I wrote a batch file that does execute the cache start, but I'm getting an Access Denied error on the cession command despite running as Administrator:

ccontrol start HEALTHSHARE1
csession HEALTHSHARE1 -U %SYS "##class(SomeClass).SomeMethod()"

Thanks for the help/suggestions

0 6
0 695
Mike Kadow · Oct 23, 2017
Invalid Project Location

I am trying to create a routine in Atelier.

I go through and enter the necessary information but before I can save, it says I have an invalid project location.

I am not sure what this is referring to, a directory? a namespace? a website? something else? "Location" does not describe what is necessary here.

I had a screen shot but cannot seem to post it here.

0 2
0 256

The Installer Manifest has the option to modify the production level settings for AutoStart but is there a way to change settings such as ActorPoolSize and other settings? What would the format be to change such a setting to change the ActorPoolSize to 2?

<Production Name="MyProduction">



0 1
0 435


I am getting the following error while logging in using LDAP authentication,

"An error occurred with the CSP application and has been logged to system error log (^ERRORS)". I've set the connection up and using Authentication Test was successful. I seem to be able to login as well but keep getting that error. If I allows unauthenticated access then the page works but changing it to LDAP is not working.

The LDAP account once created in Cache has U access to the resource related with the web application.

0 1
0 559

I was wondering if anyone has a good way to process individual messages from a queue. I run into this fairly often where I have test data coming in that I am queuing at the disabled business process, while I am working on the DTL or class to process the messages. What I would like to do is be able to send one message through to see the effects of my changes. What happens is I turn the business process back on and all of my test data goes through the current DLT/class set up. If anyone has any insight it would be greatly appreciated.


0 5
0 748

Hello Community,

I need advice converting a comma delimited string container with multiple records into some type of recordmap that iterates through all the records.

My string container has several records and I would like to loop through the number of records in the string container and transform each record in the container individually. Number of records will vary but the number of fields per record is static (28 fields). Meaning after every 28 fields, a new record begins. The goal is to convert to individual delimited flat file records.

0 2
0 417

Hi, Community!

We are pleased to invite you to participate in the InterSystems Documentation Satisfaction survey. As part of ongoing efforts to make our content more usable and helpful, Learning Services wants your feedback about InterSystems documentation. The survey covers many different areas of documentation, and you can complete it in about five minutes. The deadline for responses is October 30. Also, responses are anonymous.

The survey is over, thanks!

3 1
0 339