New to Cache/Studio. Just installed Client option for Cache (cube).

Attempting login to Management Portal for dev/tst/prd environments yields ERROR #822.

Any suggestions on where to begin to resolve would be appreciated.

Thanks!

0 4
0 2.2K
InterSystems Developer Community is a community of 16,862 amazing developers
We're a place where InterSystems IRIS programmers learn and share, stay up-to-date, grow together and have fun!

Hi Community!

Please welcome a new session recording from Global Summit 2017:

We Want More! - Solving Scalability

https://www.youtube.com/embed/yf-pj3EOSzo
[This is an embedded link, but you cannot view embedded content directly on the site because you have declined the cookies necessary to access it. To view embedded content, you would need to accept all cookies in your Cookies Settings]

0 0
0 265

I am working on a TrakCare JIRA issue that requires accessing class properties in a different installation of TrakCare on another machine. For instance, I need to compare the deprecated items in the current version of TrakCare to the deprecated items in a previous release. Is there anything in the built in classes that will allow me to do this, or is it something I'll need to do with a SQL stored procedure or something else I haven't thought of?

0 2
0 265

Hi, Community!

This post is a digest of the Developer Community postings in June 2018.

Most viewed

Atelier 1.2 Stable Release 230

InterSystems IRIS Data Platform 2018.1.1 Release 199

"IF THEN - $SELECT - $CASE" - What is the best way? 179

$CASE For Long Stories 148

Translate a number to text 147

Sort ordering 141

Extending method keywords 138

Stop Storing Atelier Credentials 133

COMANDO $ZF 130

Multi Language Sort 125

Most voted

Atelier 1.2 Stable Release 7

Translate a number to text 7

InterSystems IRIS Data Platform 2018.1.1 Release 6

Multi Language Sort 5

InterSystems on DeveloperWeek NYC, June 18-20 5

Atelier at EclipseCon France 2018 4

Installation Manifest - I can disabled the journal globals by the XML? 3

Creating SSL-Enabled Mirror on InterSystems IRIS Using Public Key Infrastructure (PKI) 3

One simple Docker trick to halve your image build time 2

DC June 2018 Release 2

Most commented

Communication link failure trying to access Studio 15

$CASE For Long Stories 14

How to convert page number to roman numeral in ZEN Report? 14

Extending method keywords 13

How to navigate to parent of Serial Object? 12

Kill process started by JOB 11

Custom file pass through Operation writing out unreadable pdf files 11

Has anyone tried REST API Put Or Post on AWS S3 ? 10

%ProcessError+6 ^%Net.Remote.Proxy.1 error occurs inconsistently 10

How to Update Caché User Full Name field via SQL? 9

Top 10 Authors to Follow by Views

Francisco López, Posts, 147

Eduard Lebedyuk, Posts, 73

Daniel Kutac, Posts, 45

Pete Greskoff, Posts, 34

Top 10 Experts to Follow

Nicole Aaron, Answers, +11

Robert Cemper, Answers, +10

Eduard Lebedyuk, Answers, +9

Vitaliy Serdtsev, Answers, +7

Benjamin Spead, Answers, +4

Francisco López, Answers, +4

Evgeny Shvarov, Answers, +3

Dmitry Maslennikov, Answers, +3

Gilberto Junior, Answers, +3

Timothy Leavitt, Answers, +2

0 0
0 177

Hi.

I would like to know if DeepSee has some feature regarding synchronization which could help me with this:

I have two tables, TableA and TableB in a 1:n relationship, and one cube for each table, CubeA and CubeB.
CubeA have a list dimension based on records from TableB.
Both tables has DSTIME parameter set to "AUTO".

Some application proccess updates data only on TableB, leading an entry on ^OBJ.DSTIME global for synchronization of CubeB.
However, as the TableA wasn't updated, there isn't such entry for CubeA.

0 2
1 199
Question
· Jun 29, 2018
DICOM Operation

I'm trying to add an Operation to store DICOM files but each time I add a Operation using the class EnsLib.DICOM.Operation.TCP it reverts into Services and I cannot work out why this is happening. I've tried following the guide online (link at the bottom) but the Operation still reverts to a Service.

Any pointers would be appreciated,

Thank you.

https://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY...

0 1
0 312

I have a service that takes a file and pass it through to the production .While I am passing the file through I get the file stream and set it to a variable within my message and the variable is of type %Ens.StreamContainer. But after all processing and I need to write out my file to a pdf format The file gets written but is a corrupt file since I can not read it I have tried this with asimple pass through everything is fine .But here I do not know what I am doing wrong here is the operation code

0 11
0 764
Question
· Jun 28, 2018
Filter in table

Hi,


is there way when select a value in filter column and the second column filter use only value referred to the first selection??

we use to active filter to column in table, but not know how relationship the filter between columns of table.

only in the table context in zen page.

0 1
0 263

What are the best steps for troubleshooting printing to a Windows printer from Cache. The printer has been configured in the Windows Printer Manager and has been able to print a test page (from the windows print manager).

The device has been configured in Cache -> Sys Admin -> Config -> Device Settings -> Devices with properly formatted |PRN|printer device name and "W" for open parameters and 101 for Alias.

0 2
0 478

I am trying to read some binary data from a local file or through socket.

The binary data is like H.264 codec, I need to read data BYTE by BYTE (even BIT by BIT) and decide the next step based on the data read so far.

I check the documentation and it seems like most of the sample focus on human readable IO, ie: LINE by LINE.

Could I achieve my goal through COS?

Thanks.

0 3
0 1.1K
Question
· Jun 18, 2018
CSP Error Log

I thought I should be able to go to the application error log or look at d ^%ER when I get the following error in the browser when troubleshooting a CSP page:

An error occurred with the CSP application and has been logged to system error log (^ERRORS)

However nothing is being generated in these logs. Where are these logs being made?

Thank you

2 9
1 2.1K

I have a class thus:-

Class RMH.ClinDoc.Response.GetEPRDisplayResponse Extends Ens.Response [ProcedureBlock]

{

Property GetEPRDisplayResult As %XML.String;

}

The property GetEPRDisplayResult contains html content.

When I write out the property in a terminal, all the html special character content is encoded e.g. '<' is &lt; '>' is &gt ; etc....

I want to display this html in a browser and have it render as normal.

So my question is how to I store html content in a cache object such that it renders correctly in a browser?

0 3
0 622

I have this local, containing a list of books of arbitrary length:

set books=2
set books(1, "author") = "Alice"
set books(1, "title") = "Hello"
set books(1, "pages") = "123"
set books(2, "author") = "Bob"
set books(2, "title") = "World"
set books(2, "pages") = "456"

And I want to generate this PDF (there could be more than two tables), each book is a separate table:

The header is always the same (Author, Title, Page) but the number of tables would be different.

0 3
0 799

Typically, I have time to review the documentation, which I'm sure is here. However, I have a workaround (TEST1) but I was wondering if anyone could assist me in advising how I would need to adapt the curly brace snippet (TEST2) to provide the same result.

Thanks for any help you can provide.

0 3
0 275