Atelier

Syndicate content 80 

When I delete a class package, it seems to delete it from my workspace but the delete action is not synchronized with the server. Is there a way to delete this package both locally and on the connected server within Atelier?

#UPDATE - Added product version information
Atelier version: 1.2.118 (Beta)
Caché $ZV: Cache for UNIX (IBM AIX for System Power System-64) 2017.2 (Build 744) Fri Sep 29 2017 11:04:53 EDT

Last answer 22 June 2018 Last comment 22 June 2018
0   0 3
161

views

0

rating

Let Say I have 
Class Carrier Extends %Persistent

Property Employee As Array of Class Employees

Class Employees Extends %SerialObject

Property Name As %String

Property Address As Array of Class AddressDetail

Class AddressDetail Extends %SerialObject

Property Street1 As %String

Property Street2 As %String


I can get value for Employee Name  as Employee_Name.

But I want to Get Value of Address Street1 and Street2 of Class AddressDetail using SQL Query
How can I get that?

Last answer 18 January 2019 Last comment 25 January 2019
0   0 2
175

views

0

rating

Hello,

We are currently in the process of migrating from Ensemble to Healthshare and I have been advised Healthshare works with the IDE Atelier. 

Does anyone know if you can change the views for transforms like you can in Studio? IE to see the .dtl, .cls and the .INT? 

It would be nice to be able to visually view the transforms like you can with Studio.

 

Cheers

Last answer 14 February 2018
0   0 3
0

comments

219

views

0

rating

Hi,

I am having a problem in REST service when de-serializing JSON using a nested Property.

I am new to Intersystems and my first time creating REST Service. I setup Atelier dev environment. The worst IDE I have ever worked in. I was able to  attach to a process in the debug perspective and step through the code, but one cannot see contents of variables nor print anything to the console, so it is useless as a debugging tool. When looking at a variable all it displays is its type of the variable and if I try to "watch" I get:

Last answer 24 February 2019 Last comment 25 February 2019
0   0 2
164

views

0

rating

When I open a BPL in Atelier and right click 'Open diagram editor' I get a Java Incompatible browser error message (see below).

I'm using Windows 8.1, Atelier 1.0.190 and IE 11.

All the M.S. updates are up to date.

I also have firefox and chrome installed.

Trying to change default browsers etc. did not work.

 

Last answer 11 August 2017 Last comment 11 August 2017
0   0 1
232

views

0

rating

When trying to do an Atelier search, the scope section shows a little red 'X' next to the server dropdown box. Hovering over it shows a message stating that "the server does not support Atelier search."

What version of Cache is needed to allow for Atelier searching?

Last answer 9 July 2018 Last comment 9 July 2018
0   0 3
96

views

0

rating

Hello everyone,

 

I'm trying to migrate the IDE for programming in COS, we normally use the Studio, but we want to use a more modern IDE. Our team has knowledge with Visual Studio plataform, but we couldn't configurate the compiler and terminal, I installed the extension InterSystems ObjectScript and tried to configurate to connect with my local machine, unfortunately the connection don't sucessed.

Someone has material for how i can connect and compile? Some material i saw show how to use the compiler, but not how can i do the configuration.

 

Last answer 3 April 2019 Last comment 8 April 2019
0   0 3
341

views

0

rating

Ok, I am trying to do my homework here but seem to be sinking.

I installed Atelier from the link    atelier-1.0.0AT.262.0-win_x64.exe  from at Atelier home page

(https://download.intersystems.com/download/atelier.csp)

Then I install Java from https://java.com/en/download/win10.jsp

Last answer 22 August 2017 Last comment 22 August 2017
0   0 3
250

views

0

rating

When assigning the filter to the server explorer in Atelier to hide system classes, it works only in server explorer.

The same server explorer option linked to a given project does not appear to observe the filter setting from the server connection, and has no ability to assign filters at the project level. Is this an enhancement needed or am i missing the logical requirement?

Also when assigning a tag to this post, only Atelier 1.1 BETA comes up. I believe i am using the stable release of 1.1

Last answer 12 March 2018 Last comment 12 March 2018
0   0 3
224

views

0

rating

Hi All,

I've got Eclipse installed (Javascript 2019-6) but when search for Atelier from the market place within the IDE it does not show up.

I found it in the browser version of the marketplace, and tried to drag it in but got the message 'The following solutions are not compatible with this version of Eclipse'.

I tried installing an older version of Eclipse (photon) but the installer keeps telling me I haven't got JRE 1.7+ installed (I have 1.8 64bit installed already), and sends me to a download page so I can't continue.

Last answer 8 July 2019 Last comment 9 July 2019
0   0 2
119

views

0

rating

I want to demonstrate using Git via Server-side Source Control hooks (to allow both Studio and Atelier to access a Shared Dev namespace), and I was planning to use the popular Caché Git hooks:

https://github.com/intersystems/cache-tort-git 

Last answer 2 September 2017 Last comment 30 August 2017
0   0 2
391

views

0

rating

Is is possible to install multiple copies of Eclipse/Atelier, and have each instance maintain it's own distinct list of server connections? I thought I had figured it out, uninstalled everything, and reinstalled without using bundle pools.  I think this keeps projects separate, along with allowing different Eclipse settings and plug-ins. After installing the second instance, no server connections from the first were showing in the second.

Last answer 26 March 2018 Last comment 28 March 2018
0   0 4
233

views

0

rating

I am trying to use current implementation of source Control for Cache Studio in Atelier, but UserAction = 3 "Run an EXE on the client" is not working. Basically Atelier is launching a "page" using the target as url.

Am I missing any settings in order to command Atelier to run a exe command instead?

Cache Version: Cache 2017.2.0.744.0

Platform: Windows 10

Last answer 28 March 2018 Last comment 29 March 2018
0   0 4
173

views

0

rating

Hi,

i have today

- update from Ensemble 2016.1.0.656.0 to 2017.2.1.801.0
- Java JDK 8 (U161) [latest Version]
- Eclipse (JavaScript & WebDev) Release 4.7.3
- Atelier 1.1 plugin (from Marketplace)
- Migrate a small testing Project

Trying "Debug":

- Debug Configurations ...
- "Atelier Application Attach" -> "New"
- Select Server, Choosing the process i want, "Apply", "Debug"

Error:

Last answer 9 April 2018 Last comment 6 April 2018
0   0 1
183

views

0

rating

I've installed Atelier according to instructions but after rebooting Eclipse there is not opportunity to launch Atelier. In preferences there is not Atelier. I've tried to update and reinstall Atelier but it didn't get a result. I checked it was installed on my PC. 

How can I solve this problem? And why I faced to this situation?

All needed components were been installed earlier.

 

Last answer 1 October 2019
0   0 1
0

comments

42

views

0

rating

In trying to understand Atelier I am directed to go through its hierarchy type of documentation.

Is the Atelier documentation going to continue as a hierarchy or at some point is it going to be integrated into the InterSystems type of documentation?

When looking for an answer it would be nice to use only one method.

Last answer 15 November 2017 Last comment 9 November 2017
0   0 1
187

views

0

rating