Atelier

Syndicate content 72 

I have previously setup an Atelier project and it was running. I recently received the 1.3 release. Now, I am unable to click on the previously established connection to my Cache server (as seen in the Serve Explorer. I see the connection and the little arrow (implying that there is a hierarchy of items underneath). But, clicking that arrow opens nothing. Ultimately, I was trying to access files on the server so that I could add some new ones to my existing Atelier Project.

Last comment 2 October 2018
0 3
0

answers

105

views

0

rating

When I try to compile through Atelier (Compile Project), I noticed that in compilation with error it returns this message 'Failed to read /api/atelier/v1/ ...':

No additional Atelier files to synchronize.
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck

Does anyone know what can it be?

I'm using Atelier beta (latest), with web application configured as Password Authenticated and a user with %ALL.

Last comment 24 July 2018
0 4
0

answers

212

views

+ 1

rating

We have started playing around with Atelier, primarily to enable us to commit our existing Ensemble code within source control (GIT). 

It seems Atelier works well with classes and routines however is unable to directly export lookup tables and HL7 schemas. Can someone confirm/validate this is the case? if so, when will this functionality be made available as it's absence is a deal breaker for us?

Lookup tables (.LUT) and HL7 schemas (.HL7) are more code and less configuration. They should be exported and kept in sync between Atelier and namespace much inline with how .cls files are handled. It is not practical to manually export / import these via Management portal every time code needs to be committed to source control.

Last comment 15 July 2018
0 2
0

answers

146

views

0

rating

Often, the first time I start up Eclipse (Atelier plug-in), all of my local classes indicate "warning" as if they are out-of-sync. When I  try to synchronize, I get the following error:

Synchronization failed: [server is broken] java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

The only way to correct this is to shut down Eclipse and restart. Is there a resolution for this?

Last comment 5 July 2018
0 5
0

answers

203

views

0

rating

Hi,

I have the Atelier plugin (latest stable release) installed in Eclipse Oxygen running on Ubuntu 16.04.2. Working well except for the BPL visual editor. When I select it, it displays a pixelated image in the view tab. Not sure if this is a Atelier issue or an Eclipse/GTK issue? Has anyone else seen this behavior?

Thanks

 

 

 

Last comment 12 January 2018
0 2
0

answers

155

views

0

rating

I am trying to go through the "Simple Project" in Atelier Workbench User Guide >>> Getting started >>> Basic tutorial.

(http://docs.intersystems.com/atelier/latest/index.jsp)

 

Under "Using the popup" it says:

Using the popup

Now that we have our project we will create a folder. We will create our folder using the Project Explorer view's popup menu

Last comment 22 August 2017
0 2
0

answers

256

views

0

rating

Good day, this is just question from  beginner, but I often use Atelier export to export my file as XML for Caché Unit Testing and I didn't find solution for my problem.

And every time I want to export I had to retype export settings again and again. On the other hand, studio always remembered my last exported data paths. Is there some option in settings to set Atelier to remember export settings please? Or there is some other way please, any ideas? (I use Atelier xml exports sometimes 30 times a hour)

 

Last comment 21 August 2017
0 2
0

answers

148

views

0

rating

Some thins I have noticed, which I am not sure are bugs or features to come.

1.) Go to type declaration (F3 or ctrl+click on a class/variable/method)

It doesn not work on object variables and methods

Where it does work, it opens the related class but it is not editable.

 

2. )There is no code indentation correction/ctrl+L ?

Is this planned?

I would very much prefer to have formatting  even if it means loosing some COS "functionalty".

 

 

 

Last comment 14 March 2016
0 6
0

answers

105

views

+ 1

rating

Hello! 

I'm trying to run a simple SQL query in atelier but it complains about the manager.  I'm not sure if this is the best way to do it but here is what I got so far:

 



	ZNSPACE "User"
	
	SET domId = 1
	SET flister=##class(%iKnow.Source.SQL.Lister).%New(domId)
	SET myloader=##class(%iKnow.Source.Loader).%New(domId)
 
 
	SET myquery="select top(10) EntityValue, CorpusFrequencyAsRelation, CorpusSpreadAsRelation from %iKnow_Objects.EntityUnique  WHERE DomainId = 1 ORDER BY  CorpusFrequencyAsRelation desc"
	SET idfld="EntityValue"
	SET grpfld="CorpusSpreadAsRelation"
	SET dataflds=$LB("CorpusSpreadAsRelation")

	SET stat=flister.AddListToBatch(myquery, idfld, grpfld, dataflds)	
		IF stat '= 1 {WRITE "The lister failed: ",$System.Status.DisplayError(stat) QUIT }
	SET stat=myloader.ProcessBatch()
		IF stat '= 1 {WRITE "The loader failed: ",$System.Status.DisplayError(stat) QUIT }


And the error I get

Last comment 14 March 2016
0 7
0

answers

204

views

+ 1

rating

I have 2 projects in atelier, A and B which map to namespace A and B on the same server.

Namespace B has some classes mapped from namespace A.

I then edit a mapped class in project A  and save it(I can see the changes in cache studio as well).

atelier A:

studio:

However in project B the class does not change, even if I click the "syncronize all files with associated namespace " button.

atelier B:

 

Last comment 10 March 2016
0 5
0

answers

149

views

0

rating

Hello! 

I'm trying to use iKnow but I get the following error "No iKnow-enabled namespaces found" in the Management Portal.

It was working on the 2015.2.2 version but now on 2016.2.0 it doesn't. I very new to Caché and iKnow so it's probably a simple problem. 

I was able to create a iKnow domain using the terminal and I can view it in the learning portal (http://localhost:57772/csp/sys/exp/_iKnow.UI.IndexingResults.zen).

What can I do to make it work in Atelier? I've tried authenticating with SYS:SYS and USER:USER but neither seem to have any namespaces.  

Very thankful for any help! 

 

Last comment 3 March 2016
0 4
0

answers

253

views

0

rating

Hello! 

I'm trying to make a simple hello world program for iKnow but the documentation only shows examples using the scripting language or XML XData. 

The domain is already created and configured, what I hope for is to be able to work with the data in some high-level language. 

Is it possible to do something like this:

 


int domainId = 1;
IKnow iknow = new IKnow( domainId );
List concepts = iknow.getTopConcepts();

Any feedback will be greatly appreciated!

Last comment 3 March 2016
0 4
0

answers

262

views

+ 1

rating

Most of projects on Caché, obviously, written not only in Cache ObjectScript, and should contain sources in other languages. Such as js or css for web-projects or any others. And it would be pretty good, if I could see all of files in one project, and possible to edit all of them. How to be in this case ?

And I think it is not a good idea, to place all project's sources in one root folder. Our project contains over 3 thousands classes and routines, and it is too difficult to find anything in such folder. Is not a good for it to use Java-way, and place every package in subfolder ?

Last comment 8 February 2016
0 3
0

answers

196

views

+ 5

rating