Atelier

Syndicate content 77 

I have previously setup an Atelier project and it was running. I recently received the 1.3 release. Now, I am unable to click on the previously established connection to my Cache server (as seen in the Serve Explorer. I see the connection and the little arrow (implying that there is a hierarchy of items underneath). But, clicking that arrow opens nothing. Ultimately, I was trying to access files on the server so that I could add some new ones to my existing Atelier Project.

Last comment 2 October 2018
0   0 3
0

answers

116

views

0

rating

When I try to compile through Atelier (Compile Project), I noticed that in compilation with error it returns this message 'Failed to read /api/atelier/v1/ ...':

No additional Atelier files to synchronize.
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck

Last comment 24 July 2018
+ 1   0 4
0

answers

237

views

+ 1

rating

We have started playing around with Atelier, primarily to enable us to commit our existing Ensemble code within source control (GIT). 

It seems Atelier works well with classes and routines however is unable to directly export lookup tables and HL7 schemas. Can someone confirm/validate this is the case? if so, when will this functionality be made available as it's absence is a deal breaker for us?

Last comment 15 July 2018
0   0 2
0

answers

187

views

0

rating

Often, the first time I start up Eclipse (Atelier plug-in), all of my local classes indicate "warning" as if they are out-of-sync. When I  try to synchronize, I get the following error:

Synchronization failed: [server is broken] java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

Last comment 5 July 2018
0   0 5
0

answers

236

views

0

rating

Hi,

I have the Atelier plugin (latest stable release) installed in Eclipse Oxygen running on Ubuntu 16.04.2. Working well except for the BPL visual editor. When I select it, it displays a pixelated image in the view tab. Not sure if this is a Atelier issue or an Eclipse/GTK issue? Has anyone else seen this behavior?

Thanks

 

 

 

Last comment 12 January 2018
0   0 2
0

answers

169

views

0

rating

I am trying to go through the "Simple Project" in Atelier Workbench User Guide >>> Getting started >>> Basic tutorial.

(http://docs.intersystems.com/atelier/latest/index.jsp)

 

Under "Using the popup" it says:

Using the popup

Now that we have our project we will create a folder. We will create our folder using the Project Explorer view's popup menu.

Last comment 22 August 2017
0   0 2
0

answers

288

views

0

rating

Some thins I have noticed, which I am not sure are bugs or features to come.

1.) Go to type declaration (F3 or ctrl+click on a class/variable/method)

It doesn not work on object variables and methods

Where it does work, it opens the related class but it is not editable.

 

2. )There is no code indentation correction/ctrl+L ?

Is this planned?

I would very much prefer to have formatting  even if it means loosing some COS "functionalty".

 

 

 

Last comment 14 March 2016
+ 1   0 6
0

answers

115

views

+ 1

rating

I have 2 projects in atelier, A and B which map to namespace A and B on the same server.

Namespace B has some classes mapped from namespace A.

I then edit a mapped class in project A  and save it(I can see the changes in cache studio as well).

atelier A:

studio:

However in project B the class does not change, even if I click the "syncronize all files with associated namespace " button.

atelier B:

Last comment 10 March 2016
0   0 5
0

answers

164

views

0

rating

Hello! 

I'm trying to use iKnow but I get the following error "No iKnow-enabled namespaces found" in the Management Portal.

It was working on the 2015.2.2 version but now on 2016.2.0 it doesn't. I very new to Caché and iKnow so it's probably a simple problem. 

I was able to create a iKnow domain using the terminal and I can view it in the learning portal (http://localhost:57772/csp/sys/exp/_iKnow.UI.IndexingResults.zen).

Last comment 3 March 2016
0   0 4
0

answers

277

views

0

rating

Hello! 

I'm trying to make a simple hello world program for iKnow but the documentation only shows examples using the scripting language or XML XData. 

The domain is already created and configured, what I hope for is to be able to work with the data in some high-level language. 

Is it possible to do something like this:

 


int domainId = 1;
IKnow iknow = new IKnow( domainId );
List concepts = iknow.getTopConcepts();

Any feedback will be greatly appreciated!

Last comment 3 March 2016
+ 1   0 4
0

answers

279

views

+ 1

rating

Most of projects on Caché, obviously, written not only in Cache ObjectScript, and should contain sources in other languages. Such as js or css for web-projects or any others. And it would be pretty good, if I could see all of files in one project, and possible to edit all of them. How to be in this case ?

Last comment 8 February 2016
+ 5   0 3
0

answers

213

views

+ 5

rating