Apple OS X

Syndicate content 6 

Hi Team,

i'm learning about CSPGateway configuration, but while trying in MacOSx i'm confused what need to done.

i have CSPgateway file, and Apache 2.4 installed on Mac. Please guide me further.

this our Inbuild private Apache with run on 57772

http://macbook.local:57772/csp/sys/UtilHome.csp   

but i want run in 80 or some other configured port

http://macbook.local/csp/sys/UtilHome.csp

Thanks

Last answer 20 September 2018
0   0 1
0

comments

104

views

0

rating

Hi All,

I'm practicing Atelier in Eclipse, but

While working CSP page.

      1. Create new Web Application 

      2.  Open CSP Web Application in Atelier Project 

      3. New CSP page -> Save

i'm getting below error Message.  

/testv1/test.csp was saved locally but could not be saved remotely.

ERROR #5912: Page '/testv1/test.csp' does not exist

test.csp is saved locally but could not be saved remotely.

Reason: /testv1/test.csp was saved locally but could not be saved remotely.

ERROR #5912: Page '/testv1/test.csp' does not exist

i'm using MacOS with Eclipse Atelier.

If i use base csp/<namespace> web application it not throw any error. 

Please share your idea to resolve. 

Thanks, 

Last answer 14 September 2018 Last comment 15 September 2018
0   0 3
130

views

0

rating

Starting with 2017.1, InterSystems has moved macOS from being a server platform to a development platform. 2017.1 will only support macOS 10.12 and will no longer be available as dmg kits.

Verification of macOS 10.12 has not been completed at this time and Field Test kits for this platform are not yet available.

Last comment 7 November 2016
0   0 2
231

views

0

rating

We just faced an issue of the Atelier main menubar being disabled (greyed out) after upgrading the macOS development machine to High Sierra. I would like to share my findings about the issue and how to fix it.

This seems to be a known problem affecting several Java applications including Eclipse if the macOS user's primary language is not English: https://www.eclipse.org/org/press-release/20170925criticalbug.php

I fixed the problem by applying the third workaround (not testing the first and second) listed in the referenced announcement as it seemed the least invasive one (just make sure to modify the Atelier.ini file instead of eclipse.ini in case of a stand-alone Atelier installation). Once Atelier/Eclipse is updated to the to-be-released Oxygen 4.7.1a version, the workarounds shouldn't be needed.

HTH,

Ondřej

 

+ 4   0 1
0

comments

253

views

+ 4

rating

Have you ever thought what could be a reason why some development environment (database, language) would eventually become popular? What part of this popularity could be explain as language quality? What by new and idioms approaches introduced by early language adopters? What is due to healthy ecosystem collaboration? What is due to some marketing genius

Last comment 17 January 2017
+ 9   0 1
666

views

+ 9

rating

Beginning with the next release after 2017.1, InterSystems products will no longer be offered on macOS (OS X) as a Server platform. This platform has been re-classified and will be available as a Development platform in future releases.

Products: Caché, Ensemble
 
Expected Availability: next major release after 2017.1
+ 2   0 1
0

comments

269

views

+ 2

rating

I tried to make atelier look more like XCODE with this simple trick or tip: change the default font to SF Mono and size 14.

To do it I did:

1) Install SF Mono font in the system which is the default font for XCODE and needs to be installed in order to use it.

You can find it in: /Applications/Utilities/Terminal.app/Contents/Resources/Fonts

Double Click SFMono-Regular.otf file and install it. You will get a warning of "serious problems" but it will work all right.

 

2) Then, in Atelier, go to Preferences / General / Appearance / Color and Fonts The choose Text Font (In Basics category) and Edit... Search for Mono and change it to SF Mono size 14.

Regarding colors I preferred to keep the Atelier default ones which they seem fine to me, but of course you can change them to simulate XCODE completely. 

See how it looks:

0   0 2
0

comments

200

views

0

rating

Hi, everybody
I am newbie at OSX and I am trying to install Cache on my mac

At first time I just executed in Shell Terminal next line
$ sudo /Users/Alex/Downloads/cache-2016.2.0.627.0-macx64/cinstall 
And there was no problems with instalation.
But few day after first try I've decided to update it to 2016.2.0.719.0 and I deleted previously installed version by "sudo rm -r <directory>" and only then I've tried to google "how to uninstall cache" and learned that I have had to stop instances and delete them by ccontrol first. My fault. Just in case it helps I did it
Then I.ve tried to execute next line 
sudo /Users/Alex/Downloads/cache-2016.2.0.719.0-macx64/cinstall 
Installation was going normally but then on task "Starting up Cache" next error was printed in termina

Last answer 28 August 2016 Last comment 27 August 2016
0   0 1
493

views

0

rating