Announcements

Hello,

Still related to the unit test with coverage support project, one goal is to make that package available to everyone.

One possible way I already know of is that all fully qualified class names (ie, the package + the class name) start with %, which mean that on installation all classes will end up in the %SYS namespace, but this requires that the install be done as a user with the necessary privileges to write to %SYS.

Last answer 1 May 2016 Last comment 1 May 2016
+ 1   0 1
286

views

+ 1

rating

We are currently looking into a way to provide a group of end-users (i.e. non-Interface Development engineers) access to a pre-defined group of Ensemble-based Data Lookup Tables for purposes of viewing and editing. We do not want to give them access to ALL Data Lookup Tables due to security/continuity concerns.

My thinking is that a simple persistent Cache table with three columns (Role Name,  Table Name, Access-Level [like View or Edit]) with a CSP front-end could potentially provide an easy way to make this solution a reality.

Last answer 29 April 2016
0   0 2
0

comments

568

views

0

rating

What would be the preferred method to create an HL7 message from an input that is not HL7?

Would it be better to take the non-HL7 input and construct an HL7 message in the business service that then gets passed off to a routing process, or would it be best to just pass the non HL7 message to a routing process that called a data transformation to create the HL7 message?

My thought is the later, due to the fact that updates to the creation of the HL7 message are done using the graphical DTL editor rather than editing COS in the service.

 

Last comment 29 April 2016
0   0 2
0

answers

326

views

0

rating

I have two servers in our TEST environment.  One with HSBUS and one with HSREGISTRY.  Let's call them "HSBUS01" and "HSDB01" respectively.

 

Now, I can access HSBUS with my SQL client by using the JDBC driver pointed to hsbus01.full.name.com and port 1972 and specifying a namespace of "HSBUS".  I am, however, unable to access the HSREGISTRY instance via SQL with a similar combination of information.

Last answer 28 April 2016 Last comment 29 April 2016
0   0 3
224

views

0

rating

We have a query that looks something like:

 

select a, b, c, d, e, f

from tbla inner join tblb on tbla.....

This query runs in the expected 200-400 ms range.

If we run the same query but reduce the select to just:

select a

from tbla inner join tblb on tbla.....

then the query runs for 30 minutes or more. 

The rest of the query is identical.  Is there a logical explanation for how this can happen?

Thanks.

Last answer 28 April 2016 Last comment 29 April 2016
0   0 2
339

views

0

rating

I have to disect thousands upon thousands of strings like this:

96842-2-AEV.00001-63561-001958-100728760I-42

I've been able to pull out the first, second and final segments as separated by hyphens, but now I have a predicament where I need to use the second segment, the 2 shown in the example above, in a join to another table.  Problem is Cache apparently doesn't like doing that.  Just the same, I have to find a way.

Here's the code I'm using to pull that segment out into as separate field in the query results:

Last answer 28 April 2016 Last comment 28 April 2016
0   0 1
613

views

0

rating

Hi Community,

How can I create a JSON with the object ID by using the %Object:$toJSON API?

I have the following piece of code bellow where I create an object reference, create a %Object instance from %fromObject and them I am creating the JSON from $toJSON, but it does not expose the %ID (object id). How is the best approach to create a JSON with the respectives object IDs?

 

Last answer 15 April 2016 Last comment 27 April 2016
+ 1   0 2
974

views

+ 1

rating

I would like to know how to close a dropdown list after selection, and also how to set the selected value to the list first to be displayed.

I can get the value by clicking the dropdown but not back to the initial state and also does not display the selected


Thanks

Last answer 27 April 2016 Last comment 27 April 2016
0   0 2
1388

views

0

rating


I'm trying to find a good way to control the Filename for X12 Acknowledgement files, but there doesn't seem to be a way to do that without custom coding.  Here's what I figured out so far:

EnsLib.EDI.X12.Service.FileService allows you to set a Reply Target Config, which would likely be an X12 File Operation.  The Service doesn’t have any settings related to the name of the Acknowledgement file though.  That’s determined entirely by the Operation.

Last comment 27 April 2016
+ 1   0 2
0

answers

337

views

+ 1

rating

Starting with 2016.2 the Java XEP binding will no longer support the in-memory connection mode. The in-memory mode was deprecated in earlier versions and applications should switch to the TCP/IP connection mode instead.

The TCP/IP connection mode has bridged the gap in performance to a large extent over the past couple of years and enables the Java client to run on a remote machine.

Let me know if you have any questions or concerns.

+ 1   0 2
0

comments

162

views

+ 1

rating

Hi,

I'm posting this for the benefit of others. Not often one changes certificates in Cache, at least in my case. I run a system, that uses certificates to encrypt SOAP messages, and since the last time I ran it, my certificates expired.

So I renewed them using our PKI tool, so far so good. I gave all (3) certificates the same names (and filenames too) as to those expired, thinking that everything would just work fine next time I call the SOAP service.

Unfortunately, I got trapped.

+ 2   0 1
0

comments

369

views

+ 2

rating

I've been using iFind indices in one of my applications but this morning discovered that the index is missing data. I confirmed the issue also exists in our test environment and rebuilt the indices there. That seems to have fixed the immediate problem. However I'd like to understand how this came about to avoid it happening in the future.

Has anyone encountered this before and know the cause?

Last answer 22 April 2016 Last comment 25 April 2016
0   0 1
285

views

0

rating

I installed Atelier on Windows in order to take a look at how the BPL and DTL graphical editors accessible via the "Open diagram editor" action work. The diagram editor is opened but I get the following error:


Message from webpage
---------------------------
Unable to load SVG diagram. Please ensure your browser is supported for portal access.


It looks like Atelier uses IE in order to display the editor even though my Windows default browser is Chrome.

Last answer 22 April 2016 Last comment 25 April 2016
+ 1   0 2
431

views

+ 1

rating

I followed the Documentation instructions to install Caché on my Linux box and it seems to be running fine except when I try to modify the configuration.  I keep getting errors that a previous cache.cpf file (e.g., cache.cpf_8503) cannot be opened.  Is my Linux "user who owns instance" account deficient in Linux permissions?

Last answer 22 April 2016
0   0 1
0

comments

151

views

0

rating

Hi! 

There is a question for Ensemble on Stackoverflow:

I have the below dtl. In the foreach loop, I am just copying the same code in another part under anif condition. How can I avoid this redundancy? Can I reuse using sub transformation?

Here is the dtl class file :https://docs.google.com/document/d/1snJXElyw13hAfb8Lmg5IaySc7md_DE8J40FB79hBaXU/edit?usp=sharing

Last answer 16 April 2016 Last comment 22 April 2016
+ 1   0 0
374

views

+ 1

rating

Good afternoon, I have image files stored on disk. I would like to display those images in an <image> control as the end user clicks on rows in a tablepane. I already do this with image data stored in a cache database:

s imageComp = %page.%GetComponentById("ImgTab"_tLdCnt)
s imageComp.disabled=0
s tId=rsId.Get("ID")
s tPageObj=##class(My.PageObj).%OpenId(tId)
s oid=tPageObj.ImageBLOB.%Oid()
s encryptedOid=..Encrypt(oid)
s imageComp.src="%25CSP.StreamServer.cls?STREAMOID="_encryptedOid

 

Last answer 21 April 2016 Last comment 22 April 2016
0   0 2
402

views

0

rating

Hi this is my first post, so a little about my background. I've been programming in PHP/JavaScript for about 10 years.  
I've got quite a bit of knowledge surrounding object orientated programming and know the basics.

Last year I looked into the Mirth integration engine and did some work around that.

I've now moved jobs and I'm doing some work (surprise, surprise) with Ensemble.

Last answer 22 April 2016
0   0 1
0

comments

402

views

0

rating

Is is possible in Atelier to open a macro declaration?  Using the context menu results in a "Current text selection does not resolve to a Script element" error in the status area at bottom of window.

Also the arguments for the macro are not shown on hover.

Doesn't seem to matter if the associated include file is added to the project.

(Version: 1.0.142, Mac OS X)

Last answer 22 April 2016
+ 1   0 1
0

comments

219

views

+ 1

rating

It looks like the normal usage of calling an Ensemble based Web Service via Ensemble is to create an Ensemble Business service that inherits from EnsLib.SOAP.Service which is then used to call a business operation which inherits from EnsLib.SOAP.Operation and the SOAP Outbound Adapter which can be generated via the SOAP wizard.

Last answer 21 April 2016
0   0 1
0

comments

378

views

0

rating

I tried logging into https://beta.learning.intersystems.com to view a video.  My browser auto filled the login form.  The username, the same one I use here and on many other ISC sites, is "sbeeson_MHCX".  Now I have a message that says "Only lowercase letters allowed" and any time I visit the login form it just shows the same message.  I cannot get back to the form.

I could obviously use an incognito window or clear my cache, but this needs to be fixed.

Last answer 21 April 2016 Last comment 21 April 2016
0   0 2
327

views

0

rating

When refreshing a html or tablePane component using refreshContents() that takes a lot of server-side-processing, I'm running into timeouts every now and then. i.e., the result for the tablePane is that there's nothing displayed at all.

How can we configure (relax) that timeout so also those heavier ones get refreshed eventually? Just overriding %request.Timeout in %OnPreHTTP did not seem to do the trick.

Last comment 21 April 2016
0   0 2
0

answers

346

views

0

rating