I use a swagger file and ##class(%REST.API).CreateApplication to create the rest api.

There is an interesting post: https://community.intersystems.com/post/download-file-rest-api-operation, but it is code, not a swagger configuration. disp.cls returns always a header content : application/json that of course fails as I am not always returning a json

I can not figure out what to put in swagger. Some examples I tried:

0 2
0 73

Trying to test a router that takes an XML input and performs a transform on it.

First attempt I tried to test the transform using the XML Document Viewer via the Ensemble -> Interoperate -> XML Document Viewer menu. The transform itself is working however I can not get the output to save to a file. I've made sure permissions are set correctly on the file. It simply doesn't output anything and I'm at a loss as to why.

0 0
0 26

Hello Community,

I'm a beginner and currently working on a project to convert CCDA files to FHIR using InterSystems IRIS. I have developed a web form to upload CCDA files, and I'm attempting to convert the uploaded CCDA files to FHIR. However, I am encountering an issue where the conversion process results in an empty entry.
Here's the Output it displays on HTML page:

0 9
0 53

How do you authenticate with a rest api? The rest api implemention allows us to add in the header Authentication: 'Basic ' + btoa(user + ':' + password) but it is not really secure as a user can inspect and with the right decoding tool see a user password

1 4
1 163

HI,

I'm migration an existing integration to InterSystems. The upstream (external) system calls a JSON web service hosted in the interface engine, which converts the JSON data received to an HL-7 messages to send to the downstream system. I'm looking for direction and example of how to do the equivalent in InterSystems, so the the upstream system only has to modify the URL of the web service they call.

I suppose in IS we'll need to create a business service that is a JSON web service? How to access the JSON data (parameters in the web service call) in the Transformation?

0 2
0 83

Up until recently, I have been toying around with REST/FHIR capabilities but only internally. Now I have a request to make REST API calls outside of our Network.

I am using an RSA 4096 key, because Microsoft Active Directory Services which generates the signed certificate could not handle the Elliptical Key (ECC) when I put the request in.

0 0
0 76

Has anyone noticed weird behavior when upgrading to HealthShare Health Connect 2024.1?

Wednesday I upgraded our TEST environment from IRIS for UNIX (Red Hat Enterprise Linux 8 for x86-64) 2022.1.4 (Build 812_0_22913U) [HealthConnect:3.5.0-1.m1] [HealthConnect:3.5.0-1.m1] to IRIS for UNIX (Red Hat Enterprise Linux 8 for x86-64) 2024.1 (Build 267_2U) [HealthConnect:3.5.0-1.m1].

Some of our Business Processes have been throwing...

1 2
0 82
Question
· Jun 27
ZF(-100) and qpdf

Hi,

I have seen your post on using qpdf with the zf(-100) function and was wondering if you could be so kind to share an example line of code. I can use pdf from the DOS command line no problems with the following:

qpdf --encrypt test123 test123 256 -- c:\test\basement.pdf c:\test\basementenc.pdf

Trying the following from the iris terminal I get a RET=2 in messages.log and the PDF is not created.

d $ZF(-100,"/logcmd", "qpdf", "--encrypt test123 test123 256 --", "C:\test\basement.pdf", "c:\test\basementenc.pdf")

Kind Regards,

Jason

1 1
2 65

IRIS for UNIX (Red Hat Enterprise Linux 8 for x86-64) 2024.1 (Build 267_2U) Tue Apr 30 2024 16:06:39 EDT [HealthConnect:7.2.0-1.r1]

I have a use case where Epic is sending an A60 Allergy transaction is set at the Patient level, but we have a system called VIBE which needs the ADT at an Encounter level instead. Currently we store ADT information in a MS SQL database for years, and we are querying it to get the latest Account Number to insert into the ADT^A60 for VIBE.

0 2
0 63

There's a distinct difference between the control sequences issued by Windows ssh.exe (OpenSSH_for_Windows_9.5p1, LibreSSL 3.8.2) vs. the RHEL 9 ssh (OpenSSH_8.7p1, OpenSSL 3.0.7 1 Nov 2022) when establishing a session to a Linux host.

Windows ssh issues the following for the Home/End keys:

^[OH - Home
^[OF - End

Linux ssh issues these:

^[[1~ - Home
^[[4~ - End

0 0
0 40

The SYS.Mirror CatchupDB() method requires a System File Number/Inode value as a parameter. I have not yet found a suitable internal method to get this value. Is anyone aware of a utility method that would do this? I do know I can get this value with a small amount of Python or by calling out to the OS. However I wanted to stick with pure Objectscript in this project if possible.

Failing in this I will use embedded python to run the line or two of Python needed to get this value.

Thank you for any hints

0 5
0 54