I have a CSP REST web application where I'm using delegated authentication via basic authentication in the REST calls. When I do a call to the web app with correct user credentials, I get a CSPSESSIONID cookie back representing the CSP session, which has started for the user I'm logged in with.

And when I want to log out/end the CSP session with the "CacheLogout=end" query parameter, I get a 401 Unauthorized code back. But the csp session itself does get terminated, which means the logout call was successful.

0 3
0 530
InterSystems Developer Community is a community of 16,862 amazing developers
We're a place where InterSystems IRIS programmers learn and share, stay up-to-date, grow together and have fun!

Often InterSystems technology architect team is asked about recommended storage arrays or storage technologies. To provide this information to a wider audience as reference, a new series is started to provide some of the results we have encountered with various storage technologies. As a general recommendation, all-flash storage is highly recommended with all InterSystems products to provide the lowest latency and predictable IOPS capabilities.

The first in the series was the most recently tested Netapp AFF A300 storage array. This is middle-tier type storage array with several higher models above it. This specific A300 model is capable of supporting a minimal configuration of only a few drives to hundreds of drives per HA pair, and also capable of being clustered with multiple controller pairs for tens of PB's of disk capacity and hundreds of thousands of IOPS or higher.

3 0
0 3.2K

Hi I am getting below error in xDBC error log

: Dispatch+14^%SYS.BINDSRV ServerLoop

When I check the detail of error I am getting below information. Please suggest as our schedule job getting failed due to same error.

0 2
0 453

I'm trying write a JavaScript generator to perform pattern match validations using existing pattern match expressions in a legacy application.

I could make a server call to perform the pattern match operation but is there a way to automatically translate the pattern match expressions into RegEx expressions so I can perform the operation in JavaScript on the client to save making an Ajax call back to the server?

Thanks

Jay Ayliff

M-Tech

0 2
0 411

Hello -

I was curious as to if there is any online documentation for TrakCare on how to default collapse this encounter timeline graph? I can't seem to find anything online so I figured I would reach out here. Instead of the timeline auto-expanding, I would simply like for it to be collapsed when opening up a patient's record.

0 2
0 474

I'm receiving HL7 message containing the escape sequence \X00D\ indicating a carriage return. In the HL7 documentation I find that this is a valid escape sequence but when I read the intersystems documentation it states that only \X0D\ is valid.

What is the best way to work around this? I think that intersystems should change the UnescapeEx method in the EnsLib.HL7.Segment so that it complies with the standards.

0 2
0 852

Hi Community!

Please welcome a new session recording from Global Summit 2017:

What's Lurking in Your Data Lake?

https://www.youtube.com/embed/FGr5CAyWcGY
[This is an embedded link, but you cannot view embedded content directly on the site because you have declined the cookies necessary to access it. To view embedded content, you would need to accept all cookies in your Cookies Settings]

0 0
0 303

I am trying to fetch the data from cache database. But i got the error like "CSP application closed the connection before sending a responce".

Below is the query.

SELECT
CallbackComment
FROM SQ.CBPhoneResult_View Where PhoneDateODBC = '2018-04-09'

I have investigated and found that "CallbackComment" contains the special character single quotes " ' " for one result and due to this i got this error.

In this field data is enter by customer. so we cannot restrict them like Do Not use single quotes.

0 30
0 1.4K

In this series of articles, I'd like to present and discuss several possible approaches toward software development with InterSystems technologies and GitLab. I will cover such topics as:

  • Git 101
  • Git flow (development process)
  • GitLab installation
  • GitLab Workflow
  • Continuous Delivery
  • GitLab installation and configuration
  • GitLab CI/CD
  • Why containers?
  • Containers infrastructure
  • CD using containers
  • CD using ICM

In this article, we'll build Continuous Delivery with InterSystems Cloud Manager. ICM is a cloud provisioning and deployment solution for applications based on InterSystems IRIS. It allows you to define the desired deployment configuration and ICM would provision it automatically. For more information take a look at First Look: ICM.

3 0
2 1.1K

Hi everyone.

I have a cube with two dimensions, DimA and DimB, with the following structure:

DimA/H1/LevelA

DimA/H1/LevelC

DimB/H1/LevelB

DimB/H1/LevelC

LevelC is modeled in such way because its bound property (C) is group by properties A and B in transactional database, but A and B haven't relation.

I can use DeepSee REST API service /Info/FilterMembers/:datasource/:filterSpec specifying each dimension one filterSpec parameter and handle the results.

But, I would like to have the results for both dimension in only on service call.

0 4
1 231
Question
· Jun 21, 2018
COMANDO $ZF

Hello everyone

I have a problem with $ ZF (-1)

I need to delete file from windows folder example c: \ sys \ text.txt, when executing the w $ zf (-1, "c: \ sys \ text.txt") command, the file does not delete.
There is some other cache command that performs this task.

hugs

Davidson

0 8
0 1.1K
Question
· Jul 4, 2018
$ZF(-100,..) issues

Hi, I found some issues with $ZF(-100) whilst replacing our old $ZF(-1) calls following the security alert. They're easy enough to work around, just figured it might be useful to someone :)

0 5
0 1.1K
Question
· Apr 26, 2018
Sync problems on startup

Often, the first time I start up Eclipse (Atelier plug-in), all of my local classes indicate "warning" as if they are out-of-sync. When I try to synchronize, I get the following error:

Synchronization failed: [server is broken] java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

0 4
0 585

Hi,

When i try to configure my server connection in Atelier (Eclipse), i am getting the below exception.

java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

It was all working fine and i think that the only thing which i have done was installing some windows updates. Now when i try to configure the server configuration i started getting the above error, any suggestions to fix this?

Thanks,

0 5
1 426
Question
· Jun 20, 2018
%Development permission issue

Hi All,

On button click from my zen page am calling the $System.SQL.ShowPlan() to calculate the cost of the SQL query.

In Cache` 2016.2 I faced a problem , when the logged in user didn't have the %development resource(<PROTECT> error).

But in Cache` 2017.2 it's working without the %development resource.

Is there any changes done on this area in the versions above 2016.2.

Thanks,

Dinesh

0 2
0 244
Question
· Aug 16, 2017
PROTECT error

I try to run below two statements

Set tRS = ##class(%ResultSet).%New("%Dictionary.ClassDefinition:SubclassOf")
​set tSC = tRS.Execute("%Persistent")

and I always get <PROTECT>check+5^%Dictionary.ClassDefinitionQuery.1

The login user is _SYSTEM and should have all the permissions.

I cannot run queries in the $SYSTEM.SQL.Shell(). I would get <PROTECT>%GenerateMetadata+16^%SQL.StatementMetadata.1

However, when I run the query through SMP, everything is fine.

Any idea where could I start to investigate ?

Thanks.

1 5
0 2.5K

or "Didn't you say you would cover Persistent Objects in Part 5, Chris?"

Yes, that was the plan. This is a pretty important topic, so it get's its own Article

Up until now, we've display widget JSON that has been created by a basic loop. Clearly this isn't of much value. Now we have our stack connected together, and we can see that the data is flowing to the Welcome page, it's time to complete the stack and start feeding our service from "real" data.

2 4
0 1.4K

Hi everyone,

I am still learning the platform for a student project and have to do some streaming and data analysis next. Since for my case I have no "live api" I wanted to just stream json files and output the data as it comes in from the files. (basically to emulate a incoming data scenario)

So thanks to the documentation and community posts I have figured how to create a stream and read data from a JSON but since I'm also new to JSON I have some parsing problems. I don't know how to access subarrays/sub-objects via objectscript.

0 2
0 2.4K

I cannot connect to Cache from node.js

I have installed in Windows 10 the following: CACHE 2016, node.js v 4.4.7 and express .

- where can I get cache.node? The link in the Intersystmes documentation http://globalsdb.org/downloads/ doesn't work. I found cache0100.node and cache0120.node in my Cache instance's \bin directory. But I am not sure if I can use them or not.

- how to install cache.node ? Where do I place it exactly?

Can anyone recommend any tutorial or code example with installation instructions?

1 12
1 3.4K

Hello Global masters,

I have some question about How can I connect C# to Cache Object without VisM?

I am always using VisM when I want to connect C# to Cache Object becouse I learn it from my co-worker .

but When I asked something in here about Cache Object and someone worte "don't use VisM because it is old thing" like that.

So I want to know about that

Thank you

Minsu.

0 1
0 323