I have run into two annoyances when using VS Code for server-side editing of Objectscript and was wondering if anyone knows of any solutions or workarounds.

 

1. In .mac routine files, class names that aren't fully qualified (e.g. ##class(example) instead of ##class(Package.example)) fail to be understood, so the class will have a red squiggly underneath it and a problem that reads

"Class 'example' does not exist. InterSystems Language Server".

00
0 2 78

Hi -

I know this is very "newby" of me, but here goes..

I have moved some classes onto my server, but these have never been in VSCode as edited files, and I'm just not finding the magic command or button or drop-down that says "pull this file from the server and make me a local copy to edit. I can see the class files on the server using the ObjectScript plugin - but I just can't find out where to make a local copy for editing

 

Thanks

00
0 2 96

Hi,

When wanting to use VS-Code for server-side editing.. - In VS-code I can right click on a server item (eg a class) to see a set of menu options including 'Server Source Control... ' and 'Server Command Menu...' at the bottom.

I noticed that these options are somewhat connected to my server-side source control hooks class that inherits from %Studio.SourceControl.Base, however, I am seeing different behavior between my custom subclass of this, and, the provided %Atelier.SourceControl subclass.

10
0 1 179

Hi all,
By using VS code, I want to copy multiple files to local directory, then sync them to server, but I can't find where local directory is stored?
In Atelier IDE, I could open a view of server and can copy the code to the project, then code is saved in the local directory. When I copy multiple files to the local directory -> choose sync in Atelier -> the code will be synchronized to the server
How to do this from VS Code?
Thanks!

00
0 14 295

My VS Code plugin "InterSystems Objectscript" upgraded to version 0.8.7 but the server settings no longer visible in extension settings and can no longer connect to our InterSystems server.

What has chnaged and how do we set the server connectio up? I checked the JSON file and it still has the settings as it was before but it is not connecting.

 

10
0 2 206