Hello!

Greetings from Chile, I have a question about IAM, I have a client who implements IAM in a QA environment, I configure a workspace and a series of routes (quite a few) and now he wants to export what has been created and take it to production (another server), which is the procedure to do it? Is it possible to export the workspace, routes, plugins, etc.?

Thank you!!

0 2
0 88

Has anyone else seen this error? From the API Manager Catalog, I can select an API and use the "Try it Out" feature. An error is returned - TypeError: Failed to fetch.

The same Curl can be imported into Postman and executed successfully. For us, API Manager is in a container and the container can ping the server. Also, this error is in the Developer Tools/Console -

0 1
0 119

I am working with InterSystems API Manager product and I'm trying to solve an authentication problem. In our implementation, API Manager accepts basic authentication. One of the endpoints accepts OAuth2. The request coming into API Manager is FHIR and needs to have basic auth in the header. The OAuth token is passed to API Manager as a parameter. I want to send FHIR to the endpoint with a Bearer Token in the header instead of the basic auth that came into API Manager. Has anyone used a transformation plug-in to solve a similar issue? I'm trying to solve this problem in API Manager ra

0 4
0 711

I am trying to create REST API following these instructions: https://docs.intersystems.com/irislatest/csp/docbook/Doc.View.cls?KEY=GREST_apimgmnt

However it does not work.

I tried downloaded the v2.0 schema.json of the OpenAPI specification and pasted it on Postman with the parameters as speicifed, but I get this error message back:

0 4
0 264

After I loaded the intersystems/iam:0.34-1-1 image in local, I am trying to do the next step of configuration.

2) Configure your InterSystems IRIS instance

2a) Enable the /api/IAM web application
2b) Enable the IAM user
2c) Change the password for the IAM user

Do we need to change these settings in iris.cpf file? any inputs where we have to configure? I have IRIS 2019.1.1 installed in my machine.

Thanks,

Nag.

0 2
0 225

I am trying to install IAM in my local and I downloaded IAM-0.34-1-1.tar.gz and extracted. I went to the location where iam_image.tar is available and run below command in the command prompt.

C:\ESB\HC\IAM-0.34-1-1.tar\IAM-0.34-1-1\IAM>docker load -i iam_image.tar
unsupported os linux

Getting unsupported os Linux issue. Kindly let me know if anyone had this issue. Thanks!

0 5
0 326