You need to enable https to your REST API. Follow these steps:

Use a proxy server to do that. Have a look at this git : or this one : (thanks @Guillaume Rongier)

Steps (thanks @Eduard Lebedyuk )

1. Install public web server (Windows, Linux).

2. Connect it to InterSystems IRIS.

3. Enable HTTPS there. Easiest way is Let's Encrypt.