· Jul 3

Why does the Rule Editor display a sad face?


I have a slight issue that's causing me some inconvenience when using the rule editor within Microsoft Edge (Version 126.0.2592.81).

Whenever I try to load up any ruleset, the ruleset displays an unhappy face like this:

This has only recently started, when opening up the rule editor in another browser e.g. Chrome, the problem disappears.

I've tried to remedy the situation by resetting Edge, Updating Edge Version, Clearing Cache/Cookies etc. but nothing seems to fix it.

I have other colleagues opening the same rule sets in the same version as Edge without any issue, so I do not believe it's an issue with the ruleset itself.

Has anyone else encountered this issue and fixed it?


Product version: IRIS 2023.1
$ZV: 2023.1.1 (Build 380U)
Discussion (3)1
Log in or sign up to continue

Hi Joshua.

Is it possible that there is a group policy in place that is being applied to you and not your colleagues? Have you tried forcing an update of your group policies applied to your profile - from the windows terminal/command line:

gpupdate /force

Alternatively, do you have any extensions installed in Edge that you don't have installed for Chrome? Maybe an adblocker?

Finally, have you tried opening devtools on this page, refreshing, and then seeing if there are any meaningful errors appearing under the Console or Network tab?

Hi Josh:

It's interesting you find it is an intermittent issue. We had some very large rules and when we turned on the new rule editor no matter what would get an :( face. 

If we deleted a few rules up to a certain amount this would load up correctly. 

If you look in your devtools when this happens it is a timeout issue where the connection is being closed prior to the rule having loaded. 

With asking WRC and pointing out the issue the :( issue was replicated in 2023.1 but did not happen in 2024.x. 

What I think it is is the gateway timeout time is too small and if you update the timeout to a bit longer it might allow the web application to load. 

Alternatively go to web application /ui/interop/rule-editor and disable the application to go back to the old rule editor. This issue and No crtl+f find functionality has caused many people to divert from the new editor until it is optimised, as well as i believe in 2023 too much whitespace.