Disabling trace Events on an active Message Router requires the Router to be stoppen and started again. After That no trace events will be logged anymore. You also should have rule logging setting of Router in mind when doing so. When starting/stoppen the Message Router consider its pool size setting to avoid side effects such as stop of Ens.Actor queue.


you could also prepare the sql´s within an editor and in the SQL browser sqlect a dialect "MSSQL". The dialect field to choose from is only visible if you click the "more" button next to the max entries to return field.

Adter that you just place your inserts and you are good to go.

best regards,

Hi Eduard,

already did this. the role %Developer should already include the %EnsRole ressources. Even assigning them to the created role manually gives me that error when logging in. Somehow as part of the login procedure, the cachelib db is accessed. Even if granting the ressources of cachelib the error remains.

kind regards,



as my advisor told me. This is a bug in Ensemble/Caché release 2017.2.2 since the intended behaviour to set sqltablename on serverside is sufficient and this specific security consideration reported a "false positive" - if I got it right a correction for this is available with ensemle 2018.1 and is identified as SAM524. The current workaround is to use both approaches setting tablename on the server and use permitclientsql = "true".

Anyway I´ll mark this issue here as solved/answered.

Best regards,