Unable to Save mac routine in Atelier

Hi ,

      I installed "Atelier" plugin and write sample routine. But I am unable to save it and run it .Please guide me how do I solve this issue.

Answers

just try a restart of Eclipse.
When fresh stated it is sometimes so busy with its own updates  

First you need to create an Atelier Project, which is a type of Eclipse project suitable for containing MACs, classes and other InterSystems code entities.

From the File menu, select New, then Atelier Project.

The RemoteSystemsTempFiles project isn't an Atelier Project. You can learn more about RemoteSystemsTempFiles here.

Comments

@Ponnumani Gurusamy - when your Atelier problem is solved and you are able to save and run the sample routine you showed us in your screenshot, what do you predict the output will be?

Based on the screen shot, it looks like you tried to save a MAC routine in the RemoteSystemsTempFiles project. This project is not related to Atelier in any way, but should not be blocking you from persisting your change to the file system. 

I encourage you to watch the getting started videos pointed to in other comments and to use the "Cheat Sheets" within the product itself. Go to Help > Cheat Sheets... > Atelier and click the first one. Go through them in order to get a good understanding of Atelier basics.

If after you've done this you are still having trouble, please contact the WRC who are best able to help you troubleshoot. 

Let us know what fixed the problem as an answer here as well please.