Rueben Van Mol · Mar 14, 2019

Studio debugger since 2018.1.1



Last weekend we've updated our Caché version to 

Versie:Cache for Windows (x86-64) 2018.1.1 (Build 312U) 


I'm using Studio to develop. I've been using the built-in debugger and it has been working nicely. But now, since the upgrade, I'm getting this error when trying to debug any routine or class method:

Executing ##class(Blue.App.Handler.Adsolut).TestConnection()


This is the code for the classmethod I got the error on;

Class Blue.App.Handler.Adsolut Extends %RegisteredObject
ClassMethod TestConnection()
  w "ok"


This is my Studio version information;

Cache' Studio Client  2018.1.1 Build 312
Server Cache for Windows (x86-64) 2018.1.1 (Build 312U)


Does anyone know what's wrong?


0 724
Discussion (11)5
Log in or sign up to continue

Right after you get this error, what's in your ^||isc.debug global?

zw ^||isc.debug

Hello Eduard,

I'm sorry if I misunderstand what you want me to try, but when I run this command from my terminal I get no result at all:

USER>zw ^||isc.debug

(including the command in the method I'm debugging isn't working either as the cursor never gets "into" the method. It stops somewhere before executing the actual classmethod...)

Yes - I just received the same error. I also just recently installed Ensemble 2018.

I have posted to my internal co-workers to see if anyone else has seen the same error. No word back yet.

There was a mention of a new method in the 2016 upgrade checklist, but I had no problems debugging in 2016.

I've copied your class into my local environment and am not getting any errors using the Studio debugger.

Cache for Windows (x86-64) 2018.1.2 (Build 309U) Mon Mar 4 2019 15:05:44 EST [HealthShare Modules:Core:15.032.9020 + Linkage Engine:15.032.9020]

Class Blue.App.Handler.Absolut Extends %RegisteredObject

ClassMethod TestConnection()
    w "ok"


Debugger executing '##class(Blue.App.Handler.Absolut).TestConnection()'
Executing ##class(Blue.App.Handler.Absolut).TestConnection()
Program has terminated.
Target has exited debugger

I created a new user with the %Developer role and verified that the class could be debugged successfully. I then added the %SecureBreak role to that user and encountered an issue similar, but not identical to the one reported by @Rueben Van Mol and @Donna.Goodall:

Invalid debugger target: ##class(Blue.App.Handler.Absolut).TestConnection()
Target has exited debugger

Yes! Thanks!

this worked for me...

We had to remove the %SecureBreak role from our user (and restart Caché). This did the trick!

Thanks guys!



I think you really only needed to log out and back in again; at least that worked for me.

As it is process private global, you should run the command from within the process, in your case from Studio Output pane.

No response there either...

Cible de
La cible a quitté le débogueur
zw ^||isc.debug


Is anyone else experiencing this error? Any ideas where to look next?