Question
Sam Duncan · Nov 12, 2020

No ObjectScript button in the VSCode activity bar

I've just installed Visual Studio Code, installed the InterSystems ObjectScript Extension Pack as documented here, connected it to a local InterSystems IRIS instance, and created a workspace associated with one of that instance's namespaces. However, after doing this, I don't see the ObjectScript button on the left toolbar when opening the workspace.

The ObjectScript extensions are installed and enabled as shown below; I've tried reinstalling them and restarting VSCode, but this doesn't make a difference:

Has anyone seen behavior like this before? I'd appreciate any suggestions for troubleshooting this.

edit: I've also right-clicked the sidebar and seen that I can toggle buttons on and off, but the ObjectScript button isn't shown as an option there.

0
0 310
Discussion (5)3
Log in or sign up to continue

This may happen if you have not opened just created workspace. You have to open any folder or workspace file.

Thanks, everyone - creating and saving a workspace in a folder and then opening the folder worked.

Since it seems like this is a fairly common problem, I wonder if it's worth going into a little more detail in the installation docs about what is needed to get the button to appear.

There are plans to get this into the docs yes