Communication link failure trying to access Studio

On one HealthShare servers (RH Linux, 2017.1.1), I am not able to login to Studio for this server. When I select the server connection from the notification tray icon, choosing Remote System Access, Studio, then the server, the error I getting is:

Unable to log on to server {Server Name}

Communication link failure

I've tried using both DNS name and IP address, same result. Using Atelier, I am able to connect to the server using the same DNS name and Web Server Port that I'm trying in Studio.

  • 0
  • 0
  • 290
  • 13
  • 2

Answers

Scott,

try to enable Audit and events Protect and LoginFailure and then check if any events are recorded in Audit log, when you try to login into Studio and see the error.

http://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY=...

I don't get to the point of trying to login. As soon as Studio launches for this connection, instead of showing the logon box, it goes directly to the error. I've never connected to it from Studio, so my username/password are not saved. There is also no entry in the audit log when I try to open Studio, no event for this is being logged.

I've also tried ccontrol stop then start on the instance.

I believe you can click Cancel on that "Communication link failure" error and then go to File -> Change namespace -> Connect -> choose the instance and then Studio will ask you for credentials

Yes, you can do that, but it results in the  same error after entering username/password and clicking OK.

If Audit is enabled
and LoginFailure and Protect events are enabled
and there is no audit event recorded when you enter username/password and see error after clicking OK.

then I would say that connection attempt from Studio does not reach HealthShare.

Can you do telnet on port 1972 from the computer where you have Studio? Instead of server specify IP-address of server with HealthShare

C:\temp>telnet server 1972
  Connecting To server...

I was mistaken, it's not port 1972, it's port 19800.  But, that is how the connection is configured, with 19800. I can't telnet from my machine, but was able to telnet to the HealthShare server that is refusing Studio connections from another server where HealthShare is installed.

If you can’t telnet to that server/port from computer with Studio then something in the middle prevents this connection. This is question for network administrators.

When you say you can't telnet from your machine, do you mean that you don't have a telnet client installed and/or cannot install one?

Are you connecting to the server via a local LAN connection or through a VPN? There may be port-range restrictions for non-local IP addresses in the VPN server's configuration. Even if you're not using a VPN client to connect, there may be a firewall between your location and the server's location that filters traffic based on source network and/or destination port. Finally, there may be similar rules in the Caché host's internal firewall that could impact connections from specific local networks or hosts. This would explain why an Atelier connection works but a Studio connection does not.

It's also possible that your workstation's firewall/anti-virus may be blocking outbound traffic on specific ports or port ranges. If it's so locked down that you can't install a telnet client to test with, I wouldn't be surprised if this was the case.

Yes, I meant I don't have telnet installed. I have admin access, will install it and try connecting. I'm connecting through  a VPN. Network team is also looking into it.

If you are indeed telling Studio to use the same Web Server Port that you're successfully using with Atelier, then that's your problem. Studio connections are handled by the Superserver port (e.g. 1972), not the Web Server one (e.g. 57772).

Studio settings:

  • IP address = {DNS name}
  • Port = 1972
  • Telnet port = 23
  • Web Server Port = 57700

Atelier settings:

  • Address = {DNS name}
  • Web Port = 57700

Those look correct.

Is there perhaps a firewall blocking your Studio host's TCP/IP access to port 1972 on your server?

Is the %Service_Bindings service enabled? Does it have any IP restrictions specified?

%Service_Bindings is enabled, has Password and Delegated checked, no IP restrictions.

I don't believe there is a firewall issue, but will investigate that too.

FWIW, my money is still on this being  caused by the Linux firewall on the server not allowing incoming TCP connections to port 1972.

I was mistaken, it's not using port 1972, but instead 19800. I am able to telnet to that machine/port from another machine, but not connect from Studio.