Replies:

Thank you so much for your help @Jorge De La Garza.

I configured the endpoint manually and configured the client details but not getting the access token back. I have created a WRC ticket to get some help from the support team. 

Thank you for help with this issue. 

Mary 

@Jorge De La Garza  Thank  you so much for your help with this issue. 

I think what I need to achieve is to get the HealthShare discovery functionality to use the specific URL for the auth server instead of the openID connect call with .well-known/openid.configuration , mainly because  it will be the Integration engine which uses the access token to get the resources and transform it to HL7 or other format of message and send it to other systems. 

Discovery URL for the authorization server I need to connect is https://xxxxx.cerner.com/r4/xxxxxxxxxxx/metadata but if by default the HealthShare OAuth discovery option is using the OpenID format (.well-known/openid.configuration) , this URL becomes invalid. Is there any way to specify the OAuth2.0 Client Discovery option to not use the openID connect and just use the URL provided in the Issuer endpoint ? 

Apologies if I am asking silly question here . I am new to OAuth.

Thank you @Jorge De La Garza .

I tried the URL with /.well-known/openid-configuration and it failed. I manged to get the correct OpenID discovery url from the  Cerner documentation and I can see the return parameter when I use the new URL in the browser but it not working in the HealthShare OAuth configuration. I am getting Unexpected issuer claim  error 

I enabled the ISCLog to 10 but it is not showing any useful information about the error. 

Also can I please check, if the OAUth configuration in HealthShare can any option other than OpenID connect for discovery?

Thanks

Followers:
Marykutty has no followers yet.
Following:
Global Masters badges: