Studio Templates and Add Ons

Primary tabs

Studio, Ensemble

We do not use the out of the box web server (57772) for HealthConnect, we run a stand alone instance of Apache with https enabled. Now when I go to Tools > Templates > Web Form Wizard,  I get an error Navigation Cancelled. I get a similar error when I try Tools > Add Ons > Add On.

Any ideas?

Replies

Any idea how to tell what the URL should be? Is there a table that lists the Add Ons? A package?

For example, Java Gateway Wizard is at:

http:://host/csp/reg/%25ZEN.Template.ObjectGatewayWizard.JavaHome.cls

I usually use "find in files" and search for page title to find where it is.

[@Jeffrey Drumm]'s answer is way better.

For the record, I checked back through the old Studio versions I have access to. This setting first appeared in 2009.1.

A bit more info on the answer from @Jeffrey Drumm

Here's how the relevant part of the 'Environment, Documentation and Proxy' section of Studio's Tools\Options dialog starts out:

In this state I can use the standard 'SOAP Wizard' add-in but it is served by the private web server of my Cache server installation. I'm testing from the Windows desktop this runs on.

I also have an instance of IIS on that Windows host, and the IIS is correctly configured to serve Portal and documentation pages from both http://localhost/ and https://localhost, plus from http://localhost/cache111 and https://localhost/cache111

Back in the Studio Options dialog I set the checkbox and start trying some value-pairs in the now-active Address and Port fields. Here are my results:

AddressPortResult of launching add-in
localhost80Success
localhost443White page, presumably because HTTP is requested from 443
localhost/cache11180CSP Error page, which reveals that the CGI variable CACHE_URL has the malformed value http://localhost:80/cache111:80/isc/studio/templates/SOAPClientWizard.csp
https://localhost443Works from Studio 2017.2.1 but fails from Studio 2014.1.1 and displays a page headed "Navigation to the webpage was canceled".
https://localhost/cache111443Fails from Studio 2014.1.1 as above. Gives CSP Error page from Studio 2017.2.1, which reveals that the CGI variable CACHE_URL has the malformed value http://localhost:443/cache111:443/isc/studio/templates/SOAPClientWizard.csp

Note too that if we enter a value for Address but leave Port blank the dialog files a value of 80 in the Port field. This can be seen when the dialog is reopened.

Conclusions from above:

  1. Templates and add-ins can be served from a server other than the Private Web Server as long as they are served from the root.
  2. Studio 2017.2.1 can fetch templates and add-ins using HTTPS when correctly configured. This is not true of some earlier versions of Studio.

In Studio's Tools menu, select Options, Environment, Documentation and Proxy. Check "Templates and add-ins will use Proxy server for <hostname>." Enter the address (including 'https://' if you're using SSL/TLS) and port number for your standalone web server. Click Apply.

You may have to re-authenticate each time you select a template, but at least you'll be able to get to them (and I'm sure there's a way around that too).

I also have a hunch that if your webserver is prepared to serve HTTP then it may be sufficient to make some server-side settings in Portal on your Caché / Ensemble server, as follows.

The settings are WebServerName, WebServerPort, and WebServerURLPrefix. These can be found in the Startup Settings ([System Administration] > [Configuration] > [Additional Settings] > [Startup Settings])

Doing this may mean you don't need to get each Studio user to change their settings. But it seems possible the server-side settings won't be able to make Studios use HTTPS for templates and add-ins rather than HTTP.