· Dec 26, 2022

SQL in Config.ConfigFile returns with fatal error


I tested the query on the Config.ConfigFile table of the Namespace %SYS, it returned 3 lines and a fatal error:

FROM Config.ConfigFile

I tested the same query on other IRIS instances (including a 2021.1 instance) and got the same error.

Is it a bug in IRIS or is there something wrong with the installations?

Anyone who can test and leave in the answers if they got the same result, I would be grateful.

Thank you for your attention.

Product version: IRIS 2022.1
Discussion (6)3
Log in or sign up to continue

That looks strange. If you execute the query via JDBC the error ist the same. A CAST to the same datatype as provided from Config.ConfigFile works:

       CAST(ID AS VARCHAR(512)),
       CAST(CPFName AS VARCHAR(255)),
       CAST(Comments AS VARCHAR(4096)),
       CAST(Name AS VARCHAR(64)),
       CAST(Product AS VARCHAR(64)),
       CAST(SectionHeader AS VARCHAR(255)),
       CAST(Version AS VARCHAR(7))
FROM Config.ConfigFile