Anderson Negreli · Dec 26, 2022

SQL in Config.ConfigFile returns with fatal error


I tested the query on the Config.ConfigFile table of the Namespace %SYS, it returned 3 lines and a fatal error:

FROM Config.ConfigFile

I tested the same query on other IRIS instances (including a 2021.1 instance) and got the same error.

Is it a bug in IRIS or is there something wrong with the installations?

Anyone who can test and leave in the answers if they got the same result, I would be grateful.

Thank you for your attention.

Product version: IRIS 2022.1
0 160
Discussion (6)3
Log in or sign up to continue

Choose Logical Mode in dropdown near the Query Builder. Perhaps IRIS SQL tries to do some Logical -> Display conversion and fails.

Logical mode worked without any problems, thanks.
But it looks like an IRIS bug anyway.

That looks strange. If you execute the query via JDBC the error ist the same. A CAST to the same datatype as provided from Config.ConfigFile works:

       CAST(ID AS VARCHAR(512)),
       CAST(CPFName AS VARCHAR(255)),
       CAST(Comments AS VARCHAR(4096)),
       CAST(Name AS VARCHAR(64)),
       CAST(Product AS VARCHAR(64)),
       CAST(SectionHeader AS VARCHAR(255)),
       CAST(Version AS VARCHAR(7))
FROM Config.ConfigFile

Interesting solution, it already serves as a diagnosis of what seems to be a bug, thank you.

The content of Column COMMENT is expected to be $LB() format.
The most likely reason is : this property contains some ages-old junk 

This works:

Name, Product, SectionHeader, Version
FROM Config.ConfigFile

Cache for Windows (x86-64) 2018.1.7 (Build 721U)