Cache Studio 2017.2

Hi all,

I hope this is the right forum to ask this type of question, but I'm running out of ideas.

For reasons beyond my control, we run a version of Intersystems Caché (2013.1) that is not supported by Atelier. As such, I use Caché Studio to do my development.
The issue I have is, I don't run Windows or MAC, but Linux (Ubuntu 18.04 in my case). I've successfully managed to get Studio working using Wine and pretty much everything is usable. 

There is just *one* issue which neither me or my peers can solve. If you hover over a line in the code editor, a tooltip reading 'First record' appears. This tooltip gets stuck and even if you open other applications/windows on your desktop, the tooltips take topmost preference..see screenshots lower down.

My question is this: I've solved almost all my other issues to get studio working in Linux by using wine regedit and just changing the appropriate keys that way. I cannot find a key/value representing tooltips however. Can someone perhaps provide the registry key I need to add/modify to completely disable tooltips in the editor (if any)?

Image 1: A screenshot of Cache Studio in the foreground (terminal screen as example in background)

Cache Studio - Note the tooltop

Images 2: Bringing another window to the foreground - note the tooltip is still there.

Bringing another window to the foreground
 

Answers

Hi Hendri,

Have you tried disabling hover tips from within Studio itself, you can find it under the top menu...

Tools > Options > Editor > Syntax Check and Assist > Hover Tips

Well done getting Studio to run under Wine, never tried it, would be interesting to read a "how to" post on it if things turn out stable / usable for you.

Sean.

I have Studio installed under Wine on Ubuntu 18.04 and accessing the Options menu in Studio causes it to crash ...

I was able to reproduce the tooltip issue, though. What I found was that if you hover over a method that actually is defined, the usual tool help for that method will display and you can switch to other windows without the annoying "First Record" artifact. Not a solution, obviously, but perhaps a workaround.

Right, probably because the settings are not in the reg to read.

In which case, the OP question asked for the registry path, which would be... 

Computer\HKEY_USERS\(your HKEY user value here)\Software\InterSystems\Cache Studio\Settings\Editor

Set the value of "Hover" to Hex 0.

Hi Sean,

The hive you referenced is already there in the registry; I'm assuming it was created during the installation of the Caché client tools. It's in both HKEY_CURRENT_USER\Software\InterSystems\Cache Studio\Settings\Editor and HKEY_USER\(user key value)\Software\InterSystems\Cache Studio\Settings\Editor. The Hover key wasn't present, so I added it as a REG_DWORD value of 0.

The behavior is different, but it doesn't solve the OP's problem ... the "First Record" tip still displays, but it no longer changes when you move the cursor to a class or method where it would normally populate with helpful information.

@Sean,

Thanks, I did indeed try Computer\HKEY_USERS\(your HKEY user value here)\Software\InterSystems\Cache Studio\Settings\Editor after your suggestion...
 


 

Comments

Hello, I use the same environment that you do 4 years long, and I've already tried everything that you imagine. I saddly realised that I'll always have this little ghosts on my work screen crying

You can use any newest version of Studio with older versions of Caché. Or you can even use Studio for IRIS, which now you can download and install separately.

The other way I would recommend is to migrate to VSCode ObjectScript. You can contact me directly so, I can help you with this process.

Hendri

Another alternative is Serenji for VSCode which works very nicely on Linux desktops as well as Windows and MAC.

It works like Studio and doesn't require exporting all your sources like Atelier and other solutions.  It will also work with very old versions of Cache such as you have.