Thanks, this works. I did have to click the "+" icon and add a new namespace to the Explorer, since adding the namespace from InterSystems Server Manager did not pull it into the ObjectScript Explorer. This is kind of an unusual case since I don't necessarily have a project/workspace for the generated class I want to view. If I already had one, then I wouldn't need to use the namespace explorer.

Depending on how specific you need to make your sorting, you can also modify the custom drilldown spec with ORDER functions. If needed, you could change the measure and the direction for each level. For example:

ORDER([Product].[P1].[Product Category].Members,Measures.[%COUNT],BDESC)
ORDER([Outlet].[H1].[Region].Members,Measures.[%COUNT],BDESC)
ORDER([Channel].[H1].[Channel Name].Members,Measures.[%COUNT],BDESC)

When executing a query, DeepSee will store intermediate and final results in the cache globals. As the engine was trying to create a new session, it looks like it could not access the database in e:\hs-db\tfoms\. Either this database is mounted read only (in this case you will need to create some DeepSee mappings) or the user executing the query does not have r/w permissions on this database.

What database is in /hs/nehi/ ? These protect errors suggest the user may not have permissions on this database

I just tested and it worked OK for me. I used the following:

Class:

Class DC.TestImport Extends %Persistent
{ 
Property TS As %TimeStamp; 
Property Bool As %Boolean; 
}

CSV:

2021-05-27 17:43:15,0
2021-05-27 17:51:13,0
2021-05-27 17:53:11,1

Import Settings:

File Name:
C:\Users\psteiwer\Documents\DC\testimport.csv
Charset:
<Device Default>
Schema:
DC
Table:
TestImport
Columns are delimited by:
Special Character: ,
First row contains column headers?
No
String quote:
double
Date format:
YYYY-MM-DD
Time format:
hh:mm:ss
TimeStamp format:
ODBC Format
Disable validation?
No
Defer Index Building with %SortBegin/%SortEnd:
No

This now works after modifying my objectscript.export "folder" setting. It was previously "src" and is now "".