Unexpected SQL error returns <NOLINE> in Intersystems Cache

Problem

I got a quick answer from this forum yesterday so I'm going to try my luck again today!  I've hit an error in another table when trying to extract through the Cache ODBC driver, but this one gives me less details and I'm struggling to pinpoint what might be causing the error.

The table I am trying to extract is called REF_TABLE_ONE.

Here's the Error:

[Cache Error: <<NOLINE>%0AmBx1^%sqlcq.PRD.2249>]
[Location: <ServerLoop - Query Fetch>]

Research/Trial & Error

Based on my research, it looks like the error results from something missing in a routine. I have limited access to this system. I am able to open up the corresponding Class in Cache Management Studio and edit/compile the code there. However, I do not have access to the "Routes" section of the Management Web Portal.

When I run the SQL Query in the Management Web Portal, I get the same error listed above, and only the column headers show up, no rows are populated.

Based on my limited analysis of the Class file, I think the issue is somewhere inside the SQLMap. It looks like there is use of Subscripts that are pretty complex. I'm wondering if there's something wrong in there?

I have the whole SQLMap code copied out, but I didn't want to post it unless someone needs it, as it is a bit long and would take up a lot of room in the post. Here's a screenshot of the visual representation of the SQLMap in case that helps: Visual SQLMap

Question

Is there anything I can do with the class code in Studio to debug or get more info about this error?

Any and all help is greatly appreciated!

Additional Info

Cache Version: Cache for OpenVMS/IA64 V8.4 (Itanium) 2012.1.5 (Build 956 + Adhoc 12486) 17-APR-2013 19:49:58.07

  • 0
  • 0
  • 125
  • 2
  • 1

Answers

Perhaps there's a faulty cached query.

The 2012.1 docs here describe how to use Portal to see what's in the cache, and how to purge items from it.

Hey John, 

Thank you for the reply, I appreciate the help!  I found the query in the cache and purged it.  Unfortunately, when I ran it again, I encountered the same error and it recreated the query in the cache, but with today's date as the creation date obviously.

Error Message

Created Cache

Any other ideas?  Thanks again, I appreciate the help :-)

Please share the code from

%0AmBx1^%sqlcq.PRD.2249

To do that open %sqlcq.PRD.2249  routine (int routine, afaik mac routine wouldn't have this )

If you can't find routines check that system saves sources for cached queries. If it doesn't set the setting to save routines, purge this query and run it again. After that you should be able to see the source.

Also can you determine which part of SQL causes this error?