Terminal Access Denied

HI,

I have been using evaluation version of Cache 2017.2, it was working fine and I was using Cache studio, SMP  & Cache Terminal/console till yesterday.

Today, cache was in shutdown status, then I restarted.  But, Cache terminal is not working and showing as Access Denied while otherthings like studio and SMP is working as expected. I checked all security level services on SMP, all are fine and enabled.

Can anyone help me to diagnose the problem and make it working.

Thanks.

  • 0
  • 0
  • 126
  • 7
  • 1

Answers

I'm guessing you're doing this on Windows, and using the "Terminal" option from the popup menu from a Cache "cube" in your system tray.

Is the cube blue? Or grey? Blue represents a locally-running instance of Cache, which is commonly how Windows folk have things, particularly when evaluating.

When you launch Terminal from your cube, what does the titlebar of the window say? It might mention Telnet, in which case you've somehow configured your cube to be connecting over telnet. When running on Windows, it's the Cache server that's responsible for operating the telnet service. Though if this isn't running you wouldn't get "Access denied", but instead a connection failure.

Please give us more information about your situation and I'm confident we'll be able to help you.

Dear John,

Thanks for help.

Yes, I am using Cache on Windows server. Cache cube is showing blue after startup and I am able to open the studio and SMP.

But, when I am trying to open Terminal, it is starting and after fraction of time it's getting closed.  and the text showing as:

 Terminal Tile: Cache TRM: pid # (Cache)

Node: WIN-GFV5BOBV5P6 (cache.ids), Instance: CACHE
 
Access Denied

<disconnected>

Cache startup and shutdown is working perfectly fine. Also, I tried to restart the windows but it's doesn't help.

Let me know, if you need any other details.

Thanks.

In Portal's Security section, check that your %Service_Console service is enabled.

What authentication methods does it accept?

The fact that your Terminal doesn't prompt for Username makes me think the service doesn't allow Unauthenticated. That's fair enough. But given that you used to be able to connect and now you can't, it looks like something changed on the config or the status of this Cache instance.

Yes, %Service_Console service is enabled and unauthenticated check box is checked.

It was working and I have not changed anything in the Cache configuration .

Is Cache terminal is depend on Windows telnet service?

When I tried to connect localhost from Studo->Utilities->Telnet, I got the below information:

Access Denied: Specified user is not a member of TelnetClients group.
Server administrator must add this user to the above group.
 Telnet Server has closed the connection
 <Session disconnected>

When the Terminal shortcut connects to your local Cache instance it does so directly and doesn't use telnet. The presence of TRM in the window title confirms that you're connecting that way, so you're not using the telnet service.

Since you're able to use Portal, please go to System Administration > Security > Auditing. If auditing isn't already turned on, do that, then repeat the failed connect. Back in Portal use the audit viewer to see if there are any clues.

The most probably you would need also to enable LoginFailure audit event in Security > Auditing > Configure System Events. LoginFailure is used to log details about the "Access Denied" event. Then reproduce a problem and look for details of LoginFailure record in View Audit Database.

Sorry for the late reply.

I tried all the suggetions but could not resolved the issue. So, I install another instance in different directory and it is working. 

Thank you all for your kind support.

I wanted to check the cost of a Cache licence and how many concurrent users/processes can be logged/run into the system?

Thanks.

I don't think the developer community is the best place for a question like that. I suggest contacting your InterSystems sales rep.