Subversion commands work at the OS shell command-line but not within the IDE...

Hi, 
I've organized my repository using TortoiseSVN. I was careful to use only svn commands while creating my file structure. Now all Subversion commands are working at the command line but not from within my IDE (Cache Studio). Basically I'm trying to write a plug-in for my IDE to use Subversion from within the Studio. Trying to integrate Subversion into my IDE, something like Subclipse, but for Cache Studio.  The error occurred after reorganizing my code into directories. For example at the command-line, svn info and svn status and all other commands work perfectly.  All Subversion commands work at the command prompt!

However, from within my IDE, svn info  and svn status commands output this error:

svn: warning: W155010: The node 'E:\elive2016\sourcecontrol\storage\XMLManager.xml' was not found.
svn: E200009: Could not display info for all targets because some targets don't exist

No Subversion command except svnadmin create works from within the IDE. The same command(s) works perfectly well at the command prompt. I run Windows 10, InterSystems Cache Studio 2016 and Subversion 1.8.12. Any help, please? 

  • 0
  • 0
  • 633
  • 8
  • 0

Comments

Hi, 

is your instance on the same machine? Anything executed with $ZF calls from within your sourcecontrol class is being executed on the instance, not on the machine your studio is running on. 

Also, check out Atelier, with it you get already working version control for not only subversion, but many more.

 

-Fab

Also, the $ZF calls made by Studio via your source control class will operate with the server credentials that the InterSystems superserver (port 1972, typically) uses. On Windows that's the logon account of the Caché/Ensemble/HealthShare service. Whereas when you launch a Caché terminal onto you local instance from your Windows desktop, your $ZF calls will use the credentials you logged in to the Windows desktop with. Similarly on non-Windows platforms.

Hi. Yes, my Cache controller for Ensemble is logged on with the root admin user of the machines on which they work. Btw, I should add that throughout the development of this practically functional system (only authentication is incomplete), this error has kept appearing.

 

Client/Server type mismatch.
Please contact InterSystems Support.

 

Haven't followed that advice yet. Maybe I should, at this point, but this forum was extremely helpful for another issue I had earlier. Will follow that directive if there is still yet no resolution to this.

Hi. Yes, my instance is on the same machine on which I work. My Subversion repository is, of course, on an external server, however. The relative directory structure is the same and the targets very much exist in the directories which the error says they don't exist. Also, two months work of developer effort have gone into building this, and it's practically complete except for this behaviour. This strange, undocumented, quirky behaviour. Also, Atelier targets only 2016.2 versions onward of Cache (correct me if I am wrong). We have projects running on Cache 2009 as well and we need version control for those projects as well. I tried Deltanji early on, and it crashed my systems pretty badly. Never went back to it after that. The entire instance became unusable. I'll take this unexpected behaviour to InterSystems if necessary, but I got great advice from this forum on creating a dialog box within Cache Studio. And hence I'm holding out for a happy ending to this whole story, hence the posts. Is there another free reliable solution for version control for InterSystems Cache for Cache 2016.1 and backward? As far as I know of, no, but again, correct me if I am wrong. (No Deltanji family of products, please!)

Sorry to hear about your experience with Deltanji. I've not been able to find any sign that you contacted us at George James Software for assistance. Given the chance, we're generally helpful folk.

Is the E: drive a real local drive, or is it a mapped driveletter intended to give you access to a folder shared by another machine?

It's very much a local drive. Thanks for your time. :-)

Did you ever solve this? If so, maybe add an Answer to the post. You can even accept your own answer (click the checkmark) and thus prevent the pot from listing as "unanswered".