Question
Sébastien Demoustiez · Sep 24, 2019

The studio is very slow on a specific namespace

Hello, everyone,

I'm trying to find solutions to a problem that's becoming quite boring.
On only one namespace, the sudio is very slow.
The studio freezes completely for 5-10 seconds when I save or compile a class. Sometimes it also freezes for no apparent reason at a random time...
It stops when I change namespace...

Do you have any idea what that could be?

Thank you in advance

00
2 0 15 252
Log in or sign up to continue

Sebastien,

I remember once customer had the same problem and it turned out that they had large amount of cached queries existent in that namespace.

Can you check and eventually delete them? 

Other than this, I can imagine some issues with source control if you have any, but this is just a guess.

HTH

Dan

Hi Daniel,

Thank you for your reply.

The large amount of cached queries is a very good idee, indeed we found some table with millions queries cached ... 

We're going to clean up the queries, optimize the code queries and see if this solves the problem.

Thank you

Sébastien

Thank you for your reply.

The mapping is actually not used on this namespace.

Thank you

Sébastien

Thank you for your reply.

Yes the source control is enabled but also on the other namespace without problems.

Thank you

Sébastien

Hi,

I'm having a similar issue but with purge queries the problem is not solved. Can you please help me to fix it?

I'd like to try the last comment " the routine index was corrupt, recompiling all routines" but I don't know how to do it.

Thanks in advance

In terminal : 

USER>d ^%RCOMPIL
 
Routine(s): *
Routine(s):
Display syntax errors? Yes => Yes
Display on
Device:
Right margin: 80 =>
 
Compiling in namespace USER at 11:26:55
xxx.MAC    xxx3.MAC    ...
nn routines compiled with 0 errors at 11:26:55 in 00:00:00.029

In portal : System Explorer -> Routines 

Thank you very much for your explanation. Very clear.

I can do the recompilation of the routines but the studio on the namespace is still very slow.

I don't know what els can I try.

Do you have any idea?

Thanks

Hi Joan,

Are there many routines in the namespace ? Is the studio faster on other namespaces ?

Any special mapping in the namespace ?

Have you tried creating a new namespace and exporting/importing some routines to that namespace ? (or map routines to the new namespace)

Hi Danny

Other namespaces work well. I tries to purge queries and this improves a little, but I'm still unable to open, close or work with the studio.

I don't think there is an special mapping on the namespace. This should be something of my environment because my partners don't have this problem.

I don't know what els I can try.

Thanks in advance

If your partners work in the same namespace without any problems, you might want to reset the Studio settings to default, or use their settings:

Studio menu Tools -> Import and Export Settings
First export your settings as a backup, and than reset All settings (or import a setting from a partner)
 

Thanks for your responses.

I tried both, reset an import from a partner but there is no changes.

Any other idea?

Thanks in advance

Hi Joan,

hmm, running out of ideas,

can you create a new namespace (or use e.g. USER if not used), and map some routines from your database to that namespace. Is Studio also slow in that namespace ?

Any special mappings in that namespace? Size ?

Try to export classes and routines from that namespace and import them in a new namespace, is it still slow in the new namespace?

Maybe you have source control enabled in this namespace?

We had a similar issue at a site and it turned out the routine index was corrupt, recompiling all routines solved this.