Soap Wizard

HI,

Please let us know the solution to the below error:

ERROR:#5388 - You do not have write permission on the database class .
%SOAP.WebClient is in , so class lock cannot be obtained .

Thanks,
Shobha

  • 0
  • 0
  • 385
  • 5
  • 2

Answers

Have you tried to compile %SOAP.WebClient class in Studio? This is how this message can happen, because you don't have write access for CACHELIB database by default. 
 

Hi Shobha,

It always helps to provide a detailed explanation of your technical problems in order to receive back the best response you are looking for. Or from another perspective the more time you put into your question, the more time you are likely to receive back from community members giving their time to help others.

The error that you are getting is because you have tried to compile the %SOAP.WebClient class. This is an internal class to Caché and should not be included in your compilation step. If you try to compile it you will get the permission warning that you have received.

What we need to understand is why you are trying to compile this class, or the steps that have lead you to trigger a compilation on this class. We can then figure out where things are going wrong and hopefully steer you in the right direction.

In terms of your more broader questions...

"I am using SOAP Wizard to create Web client and Services , I want my Ensemble Production to accept the SOAP message and pass  it to the Operation. Please let us know how it can be achieved."

Again, it would help to have some background in order to know how to best help you. Are you new to both SOAP and Ensemble? Has the documentation helped that we pointed you towards a couple of days ago? What is the overall project goal. For instance, do you need to create a SOAP service from scratch, or are you linking up existing SOAP services?

Sean.

HI Sean,

 

Objective : To accept a SOAP request message in an Ensemble Production and get back the SOAP response.

 

The document provided (http://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY=...) has helped us partially.

The steps we have followed are given below:

In the studio we selected SOAP Wizard option and provided this URL :http://www.thomas-bayer.com/axis2/services/BLZService?wsdl  .

In the next step , we checked the create Web Service , Create Business operation boxes and Package Name.

Once the Finish is done it generated the appropriate classes , but each time we got an Error given below:

 ERROR #5805: ID key not unique for extent '%Dictionary.ClassDefinition' : '^oddDEF("GuruBaseAllah.BLZServiceSOAP11porthttp")' exists. Id counter location = '' .

 

Please let us know what has to be done next .

 

Thanks,

Shobha

 

 

Hi Shobha,

I've just had a couple of attempts using the same wsdl and package name that you are using, as well as trying a few variations in the settings.

On each attempt the wizard outputs a successful generation for me and I was unable to re-create the error that you are seeing.

The problem might be related to your specific version of Ensemble, or there could be something odd going on with dictionary mappings that needs to be looked at.

I would recommend contacting your local Intersystems support for more help on this matter.

Sean.

Hi ,

 

I am able to create a Web Service successfully using the SOAP Wizard also able to open the web page locally .

But there are two methods in the Web service which is created and cannot be opened / Run /Invoked.

( wsdl used : http://www.webservicex.com/globalweather.asmx?wsdl )

Please let me know how to proceed.

 

Thanks,

Shobha

Comments

What are you trying to do? Where/when are you getting the error?

-Fab

Hi,

 

I am using SOAP Wizard to create Web client and Services , I want my Ensemble Production to accept the SOAP message and pass  it to the Operation.

Please let us know how it can be achieved.

 

Thanks,

Shobha