Question
Charles Me · Apr 27

Running Cache on LocalHost

Hi,

I am not able to connect to the local web browser.

If I try to open documentation (http://localhost:57772/csp/sys/UtilHome.csp) I get

Caché Server Pages Version 2018.1.6.717.0
Server Availability Error

Server is currently unavailable

If I call up the log CSP.log I have the following:

Access Denied
    Diagnostic
    Failed to connect to 'LOCAL' - Reason: 0 (Connection successfully made but server not responding) (No Retry)

I cannot figure this out

Product version: Caché 2018.1
0
0 135
Discussion (8)2
Log in or sign up to continue

Hi Charles,

I'd check your Caché audit log or cconsole.log.

I will try that and report back.

This just happened to a client - check the CSPGateway password. Try resetting it.  Did you just install any OS patches?

I can connect with the CSPGateway password on port 80.  My issue is with port 57772.  would deleting CSP.ini in the /csp/bin directory reset the password?

I noticed that the original title of this post was "Can I run Caché using SSL?," so I'm wondering if you have SSL/TLS set as Required in System-wide Security Parameters in the Management Console, or even Enabled with an incorrectly configured CSP Gateway ...?

I can't exclude I did not do that at one point.  Again this is on the 57772 configuration, IIS works.  Where / how can I check for the settings please?

Assuming Caché Terminal is working, you should be able to access these settings via the ^SECURITY menu.

Sign on via Terminal with an administrative account (SuperUser,  cacheusr,  _SYSTEM) using the password you provided during installation.

Change to the %SYS namespace using the command zn "%SYS"

Issue the command do ^SECURITY at the %SYS> prompt.

Choose System Parameter Setup

Choose Edit system options

Press Enter until "SSLServer connect type" displays with 3 options

Choose 1 to disable SSL (the current setting may be displayed near the end of the prompt)

Press Enter to step through the remaining prompts, and confirm changes to the security parameters.

Exit from the menu, and type h followed by Enter to exit the session.

Thank @Jeffrey Drumm 
It was set to 1.

What I have done is take the CSP.INI file of the Apache server and delete the lines for Username and Password and try to reconnect.

I now got the Web Gateway Management Page :-- http://localhost:57772/csp/bin/Systems/Module.cxw -).  So I have an interface. 

I reentered the username and password. For  the record my passwords are generated but (I am assuming) if they work on the IIS version of CSP Gateway it should work on the inbuilt one.

Connecting to the server gives: Server Availability Error / Server is currently unavailable 

I will see the audit and update

I reset the password and it is working.  Still baffled why it worked on one interface but not the other.

Thanks everyone