No Namespaces found

Hello! 

I'm trying to use iKnow but I get the following error "No iKnow-enabled namespaces found" in the Management Portal.

It was working on the 2015.2.2 version but now on 2016.2.0 it doesn't. I very new to Caché and iKnow so it's probably a simple problem. 

I was able to create a iKnow domain using the terminal and I can view it in the learning portal (http://localhost:57772/csp/sys/exp/_iKnow.UI.IndexingResults.zen).

What can I do to make it work in Atelier? I've tried authenticating with SYS:SYS and USER:USER but neither seem to have any namespaces.  

Very thankful for any help! 

 

  • 0
  • 0
  • 262
  • 2
  • 0

Comments

Hi Benjamin,

in order to enable a web application to use iKnow, you need to check the "iKnow" box in the SMPs Web Application management page (System Administration > Security > Applications > Web Applications). This was mentioned in the release notes of the first version introducing the stricter security policies (or at least the routine behind the checkbox is), but isn't mentioned prominently enough in the iKnow guide. We'll look into that.

This is actually only related to the web interfaces, so Atelier is not involved here. To create iKnow domain definitions through the management portal, look for the "iKnow Architect" in the SMP menu for iKnow.

 

regards,

benjamin

Re your Atelier issue, does the "Configure server" link lead you to somewhere you can test the connection? Make sure that your Atelier connection is pointing to the port that your Cache Portal also goes to, and not to the port that your Cache Studio uses. That was an early gotcha for me in Atelier.

The Cache username that you connect with might not have enough privileges. One way to determine if this is you problem is to grant the user the %All role temporarily.