Interpreting icons in Atelier Explorer view

While testing Atelier 1.0.255 I noticed that the namespace subtree of my Atelier project used different icon shading for the top-level Classes folder compared with the top-level Routines one:

Drilling down into parts of the Wasabi package helped me work out the significance of white-filled icons versus brown-filled ones:

A package is white if there are no classes in it, but only subpackages.

As a footnote, this only happens when browsing the namespace within Atelier Explorer. If you do the same on the Server Explorer view, all the packages are brown - another puzzling inconsistency between these two views:

 

  • + 1
  • 0
  • 251
  • 8

Comments

John, this looks like a bug to me. I'll file a report with development and let you know what I hear back. Thanks for pointing this out!

Thanks Nicole. My previous post about inconsistencies between Atelier Explorer and Server Explorer is here and I hope the outstanding issues I identified there have also been filed somewhere that they will get attended to by development.

The other issues you reported are on file and will be addressed when development is able to pick them up.

The development team plans to address the inconsistency of the white package icons in the server section of the Atelier Explorer with Atelier 1.1.

Nicole, this inconsistency between Atelier Explorer (where some packages are shown as white) and Server Explorer (where none are) still exists in 1.2. For example, in AE the %Compiler package is white because it contains no classes, only subpackages:

In SE this doesn't happen:

Is it still on someone's radar there?

Hi John, yes this is still on the dev team's radar. There is a development issue filed to address it. However it is not a high priority at the moment. Let me know if you'd like me to create a WRC case in your name linked to that dev issue so that you can monitor its progress in your WRC application.

All set, John. You should see WRC 899885 when you log into the WRC application.