How to Make a Post and Other Frequently Asked Questions

Primary tabs

DC Feedback

Hi, InterSystems Developer Community!

We are working to improve this site to make it comfortable to read, contribute, share and get answers from InterSystems Developer Community!

But while we haven't fixed some UI issues please find in this post some simple answers on how to deal with Developer Community.

How to add post?

Open Communities page, choose desired e.g. Caché and click "Create New Post" button.

 

How  to subscribe to the post's updates?

To subscribe to post's updates and get them via email click on Favorite link under the post digest.  For example:

 

How  can I manage post's header ?

Suppose you've created article and want to add several sentences in it's annotation.

To do it switch Editor to "Filtered HTML" mode and enter <!--break--> tag in the end of annotation.

Otherwise your annotation will be trimmed to one-two sentences. Like here:

To be continued. Stay tuned!

Comments

Hi, thanks for this post. I just introduced to this community and loved the idea of ​​having my questions about Intersystems products shared. 

Are there any plans to support RSS?

Hi, Victor! Thanks!

Yes!

There is a discussion about this. It's not working properly now but is planned to fix and introduce this service.

Looking forward to see your questions about InterSystems Products.

 

 

It's the tag which helps post's author to manage how many sentences of the post people can see in the feed here.

This post has been automatically cut to 2 sentences:

My post is cut where I decided to do it

And I can manage it with <!--break-->

Makes sence?

Yep, when I tried it the only thing it *broke* was all my formatting.  I'll play with it some more though.  Thanks for elaborating and especially for the comparison screenshots.

You are welcome, Scott! Did you change the editor to html? 

And hope your comment means +1 too,  am I right? )

I just had a similar problem. Currently, you have to switch to HTML mode, inject the break tag and switch back to WYSIWYG mode before you save the change. Don't save your formatted post in HTML mode. At least that worked for me.

Today was Community Portal update wich added Create New Post button even on main page which is obviously is more convenient.
So if you want to make a post you can do it on the main page now.

Looking forward to see  your new posts!

It looks like the star rating was updated too.  I think it's actually worse though.  There is still no indication that you clicked a rating and now when you refresh the stars aren't visibly "filled in".  Instead there is a new line of text that describes the votes.  Also, the stars look worse in general in my opinion.

Content rating is going to get completely reworked, most likely to the +1/-1 system. Any change to the current rating scheme was unintentional. We'll be doing releases each week for the next few weeks and rating changes will likely be in the release two weeks from now. Next two releases will focus on the following:

- more UI layout and usability enhancements

- improvements to authoring / editing

- new content types (articles vs. generic postings)

- internal tools for porting content from other systems

- new content filtering options

 

I tired using the <!--break--> tag in a recent post, and no matter where I placed it there was no change.  Can you provide a snipet showing a sample in the Filtered HTLM editor?

Some notes:

  • When writing a post title don't use URL escaped characters (namely - é). Title goes into url and it may break the link
  • To add code switch into Filtered HTML view, paste your code inside<pre> </pre> tag, afterwards switch into Community Member WISIWYG to post
  • To add headings use <h1> to <h6> HTML tags (in Filtered HTML view)

If you paste table from somewhere else, when creating a post, sometimes borders may be undisplayed. To fix that switch into HTML view (via "Disable rich-text" button) and find the beginning of your table definition. It would look somewhat like that:

<table class="confluenceTable">

And replace it with:

<table border="1" cellpadding="1" cellspacing="1">