ERROR #822: Access Denied

Primary tabs

Hy.

 

I set up cache in container, which is working fine. But when accessing managment portal the default user was alway Unknown user and no username or password were required. So i disabled the Unknow user in the Security section, but now i keep getting an error access denid. 

Replies

What do you want to fix? Locked access or change security level?

Mostly when you run some server application inside a container, it means that no needs any changes of settings, while this container is up because all that changes may disappear after restart container form a new image.

I would recommend changing security level in the installation process. You can do it with some environment variables described in the documentation. Just add this lines in the Dockerfile before cinstall_silent command

ENV ISC_PACKAGE_INITIAL_SECURITY="Locked Down" \
    ISC_PACKAGE_USER_PASSWORD="secretpassword"

And your installation will be secured.

Read more about initial security settings in the documentation.

Thank you for the info

 

I want to fix locked access, but i will first try to change security level in installation as you suggested.

You can reset all changes which you did, when you start newly created container from an image. Use docker run with a flag --rm to remove container after exit.

Hi Dmitry,

I have the same problem as Natasha except I could not. I get the same error. There is no way to activate the user "Unknow user"? The error window has a "Click here for get access" link but it does not work.

The strange thing is that from the Web Gateway Management I can make a satisfactory test to the server.

Can you help me with any ideas?

Regards

Hi, could you explain a bit more? What are you trying to do? Do you use Docker?

My problem was that I had disabled the user UnknowUser and could not access the management portal. I needed to reactivate the user. He could not access the terminal either.

The solution that you proposed to Natasa and that it worked for her, used by Docker, the reality is that I did not know how to implement it since I do not know what is docker. I thank you that you can tell the community about what goes docker and so we document a little more.

Thank you !