Question
Graham Hartley · Nov 18, 2020

Delete HL7 Standard Schema

Hi,

I am trying to delete a HL7 standard schema i created by mistake however when i select delete in Studio i get the following:

The xml is as below:

<?xml version="1.0"?> <Category name="WYT.2.4" std="1">...

i then remove the std so it becomes:

<?xml version="1.0"?> <Category name="WYT.2.4">...

Then i get the error:

I have also tried exporting and importing the schema with the std part removed but still get an error.

We have IRIS 2020.1.

Any ideas?

Thanks,

Graham

00
2 0 2 123
Log in or sign up to continue

Hi Graham,

Removing the std attribute was the correct way to avoid your original error.  The new error that you are seeing indicates that there is a typo in your MessageStructure definition such that the total number of opening and closing brackets do match, but somewhere the definition includes "~]k~", which is not allowed.  There should be a "~" separating the bracket and any segment references; since there isn't, we are interpreting the "]k" as being a segment reference, but, of course, that is not a recognized SegmentStructure name.  My guess would be that the "k" was added accidentally.

-Kimberly

Thanks for this - I located and fixed the typo.

Regards,

Graham