Can't install Caché on Windows 10

Hi,

somehow my installation on win10 canceled during finish. "Installation of Caché finished" showed up for 20 minutes and canceled with an error I didn't saved.

Every file and service was installed but never registered as successfull installation. Now I try to reinstall it but the installer shows me everytime "Another installation is already in progress. Please finish the second installation first".

The unfinished installation is broken. I can't startup Caché from launcher. So I deleted everything in c:/intersystems

Things I already tried:

- Removing all Temp-Files with the cleaning tool from Windows (also "Clear Systemfiles")

- Remove from "Programs" list (it's not there due to unfinished installation)

- Restart Computer

- Searching registry for LOCAL_MACHINE/Microsoft/Installer/InProgress (not found)

- Searching registry for LOCAL_MACHINE/Microsoft/Current Version/Installer/InProgress (not found)

- Searching filesystem for temporary Installation-Files from ISC (none found)

- Searching registry for ISC entries (only non necessary keys found like "last searched terms", and entries for the services like CacheHTTP)

- C:/Intersystems- Folder is not present (my installation directory I deleted earlier)

- No Process of "Windows Installer" is running

- sfc /scannow -> no Results

 

Where is the flag located that an installation is already in progress?

I can't even install another instance with that problem.

 

EDIT:

Got the error :

Product: CACHE-- Error 1719. Windows Installer Service could not be accessed. 

 

The Windows Installer Service is active

I don't know

 

EDIT2:

There was a msiexec.exe in my process list (also after restart). 

I killed it and now I can install but now the next problem arrives (installation started with admin-rights):

 

 

Everything started:

Installation will not finish, Caché-Launcher is not in Task-Bar.

It cancels again with "Windows Installer Service not available". 

Trying to reinstall the instance gives me "This action is only available for products that are already active"

 

Wierd problem. Something in Windows wants to f+++ me up. I post a solution as soon as I have one

 

EDIT 3 / Solution:

Reinstalled Windows

  • 0
  • 0
  • 129
  • 4
  • 2

Answers

Hi Jochen.

Have you looked at Microsoft forums?

There are lot of posts there with similar "Another installation is already in progress" error.

For example, following:

https://answers.microsoft.com/en-us/windows/forum/all/windows-10-error-m...

Currently it looks more like a problem with Windows Installer than with Caché

I already saw that post. I should've scrolled further. There was a msiexec.exe frown

But now I have the "Cache initialisation finished-problem"

Edit on post coming as soon as I have the error.

What version of Caché are you attempting to install? Windows 10 began being supported with Caché 2016.1.

Given that there was an incomplete install I would recommend uninstalling Caché, restarting, and then trying a fresh install.

Comments

It might be unrelated, but I recently had a similar issue when installing healthconnect on a windows 10 machine with Kaspersky Endpoint Security.

Kaspersky was being triggered by some temp files created by the installer, and placing them in quarantine. This was then leaving the installer showing it had completed, but with the progress bar still showing. I never did leave it for as long as you did to then get the error you didn't save.

The weird thing was that Kaspersky only reported a virus with the installer on specific versions of Windows 10.

I ended up submitting the installer to Kaspersky so that they could white list it. 

Long story short, check the reports section within Kaspersky and see if it interfered with your install. smiley

I reinstalled my machine. Somehow Windows Updates didn't installed as well before. I wish I could check these Kaspersky-Logs, but now it's too late. Maybe it's really something that they prevented. Nevertheless our group-policy should've uninstalled it months ago. Didn't work either. 

So a clean install of Windows 10 was a good solution here.