Authentication Error

Hi All,
I tried to execute the ##Class(%SYS.LDAP).Binds(LD,"",$lb(Username,Domain,Password),$$$LDAPAUTHNEGOTIATE) but this command is returning the value as 7 only instead of 0,7 is an "Authentication Method Not Supported",How to recover it and why this error message is occuring
Please help me

  • 0
  • 0
  • 45
  • 3
  • 0

Comments

Are you connecting from a Windows Client to a Windows LDAP server? Or is it an Unix Client to a Windows LDAP server? Its a matter of using Binds vs SimpleBinds. I am wondering if that is causing your error. I use Delegated Authentication through LDAP using a TLS certificate so my setup maybe more complicated than yours.

Hi Scott, thanks for the reply.
Yes i am using windows to connect to LDAP.
I am using the Binds method. i have enabled the Delegated authentication option in LDAP options and disabled the TLS option.

And again i tried the whole process in a different machine (windows) now i am facing invalid credentials errors as shown below

"0 p‰'LDAP Binds Error: Invalid Credentials< SAMPLES0'e^zAuthenticate+30^User.NewClass1.1^1e^^^0"

Note:
I have tested the LDAP connection using the d ^SECURITY method and it came ok.

Please help

thanks

@sansa stark - seeing that you have posted 3 DC questions about LDAP in the past ten days I strongly recommend that you contact WRC (i.e. InterSystems Support) so that they can work with you interactively on your problem(s).