Atelier 1.2 has landed!

Just now when I started up my Eclipse I was offered an Atelier update. After waiting for so long, how could I possibly refuse? Wish me luck! laugh

  • + 1
  • 256
  • 8

Comments

Update: starting with a fresh Eclipse workspace seems to be helping...

For the record, it seems 1.2 has appeared in the Beta repo that's documented at https://download.intersystems.com/download/atelier.csp#plugin - 

https://atelier.artifactoryonline.com/atelier/updates/beta/latest/

Hi, John - thanks for pointing this out. You'll want to run Eclipse with the -clean argument to clear all cached plug-in data. There's a good discussion about that on StackOverflow here.

I'd suggest adding the clean argument by launching Eclipse from the command line (less risk than adding it to the eclipse.ini and forgetting to remove it).

I switched to my upgraded 1.1 workspace and tried a couple of times launching Eclipse with 'eclipse -clean' but still get the errors. It's not critical for me, as it was only a play workspace. But it might matter more to other folk if they have the same experience.

Right you are John. I sent you the wrong flag+StackOverflow page, sorry about that. The command-line flag you'll want to add is:

    -clearPersistedState

This will clean persistent workbench data. Then you'll need to re-open the Atelier perspective, or the Atelier views that you use.

Nicole, after starting once with the -clearPersistedState command-line switch I am now able to use my original workspace.

Intriguingly, after doing this both my original workspace and the fresh one I had created after upgrading to 1.2 now complain about connecting to a server whose /api/atelier web app only accepts Unauthenticated access. Before "-clearPersistedState" my freshly-created workspace was willing to connect to such a server (incidentally, that server was a fresh install of IRIS 2018.1.1, which still offers Minimal Security as an install option).