Why can't I have CSP Gateway files where I want on a cache_silent install?

Hi!

I have the following script to install caché silently:

#!/bin/bash
ISC_INSTALLER_PARAMETERS="SuperServerPort=1972,WebServerPort=57772,InstanceOwner=controller" \
ISC_PACKAGE_INSTANCENAME="AUPOL" \
ISC_PACKAGE_INSTALLDIR="/myapp/cache" \
ISC_PACKAGE_UNICODE="Y" \
ISC_PACKAGE_INITIAL_SECURITY="Locked Down" \
ISC_PACKAGE_MGRUSER="controller" \
ISC_PACKAGE_MGRGROUP="wheel" \
ISC_PACKAGE_USER_PASSWORD="password" \
ISC_PACKAGE_CACHEUSER="cacheusr" \
ISC_PACKAGE_STARTCACHE="Y" \
ISC_PACKAGE_CACHEGROUP="cachegrp" \
ISC_PACKAGE_CSP_CONFIGURE="Y" \
ISC_PACKAGE_CSP_GATEWAY_DIR="/myapp/cspgateway" \
ISC_PACKAGE_CSP_SERVERTYPE="Apache" \
ISC_INSTALLER_MANIFEST="/tmp/myapp/unpack/DefaultInstallerClass.xml" \
ISC_INSTALLER_MANIFEST_LOG_LEVEL="3" \
ISC_INSTALLER_LOGFILE="/tmp/myapp/installer_manifest.log" \
./cinstall_silent

 

This is called form an Ansible script. It works, but the csp gateway files are being installed on /opt/cspgateway no matter what settings I put on ISC_PACKAGE_CSP_GATEWAY_DIR.

What can I do to have the CSP Gateway files under /myapp/cspgateway? That is important to me because I will make a snapshot of  /myapp filesystem before applying upgrades and patches.

 

Kind regards,

AS
 

  • + 1
  • 0
  • 302
  • 2
  • 2

Answers

Actually there are two causes, of this.

First, is a quite simple, installation script looking at previous installation, and can't change if it was already installed in another folder.

But next reason, it is just a small typo in installation script, which suit only for silent install.

file package/csp_gateway/parameters contains CSPGATEWAY_DIR variable instead of CSPGATEWAYDIR

you may just add this line to your installation script, to fix this error.

sed -i '' -e 's/CSPGATEWAY_DIR/CSPGATEWAYDIR/g' ./package/csp_gateway/parameters

And I think, you should ask WRC to fix this error in all next builds.

This workaround works like a charm! Thank you!!!

Hi, even having CSPGATEWAYDIR in the package/csp_gateway/parameters file csp is not getting installed in specified directory and keep saying "CSP Gateway: using built-in web server".

So both these below params having no effect.

 ISC_PACKAGE_CSP_SERVERTYPE="Apache"\
 ISC_PACKAGE_CSP_GATEWAY_DIR="/u01/cspgateway"\

I worked with Amir on this issue. The problem is caused by a bug, and the fix is already implemented (ALE2918), which will be included in future releases. Right now, the plan is to include the fix in 2017.2+.