Question
Kurro Lopez · Jul 21

Webterminal broken :(

Hi all,

I've just  update the version of WebTerminal using the link, but now it doesn't work.

When call to /terminal is displaying the following error:

{
    "errors":[ {
            "code":5002,
            "domain":"%ObjectErrors",
            "error":"ERROR #5002: Error de cache: <INVALID OREF>zWrite+5^WebTerminal.StaticContent.1",
            "id":"ObjectScriptError",
            "params":["<INVALID OREF>zWrite+5^WebTerminal.StaticContent.1"
            ]
        }
    ],
    "summary":"ERROR #5002: Error de cache: <INVALID OREF>zWrite+5^WebTerminal.StaticContent.1"
}

Anyone has had the same issue and has fixed it?

Best regads,
Kurro

Product version: IRIS 2021.1
$ZV: IRIS for Windows (x86-64) 2021.1 (Build 215U) Wed Jun 9 2021 09:39:22 EDT
0
0 101
Discussion (3)1
Log in or sign up to continue

I haven't seen this problem.

The GitHub source of this method doesn't seem to check the status of its ParseStream call before trying to read the stream:

Maybe your upgrade procedure went wrong. I suggest you download the XML distribution and import it again.

Thanks John,

We've reinstalled it using the dowload packaged from the website. Now it works.

This is the second time that the link in the WebTerminal doesn't work.

Thanks againg mate.

Best regards,
Francisco Lopez

Were you logged in as a user with the %All role when you clicked the update link in WebTerminal?