Is there any settings for do automatic logout in intersystem.

If the session is in inactive state for some time. It should be logging out automatically. Is there any settings for that??

Answers

I have done the setting but it is not logging out. I am getting this below error. Even i tried keep alive disabled in CSP Gateway. Even though it is not working.

What exactly did you do?
Quote from doc:

By default, the session timeout is to 900 seconds (15 minutes). You can change this default for a CSP application in the Management Portal; [Home] > [Security] > [Web Applications] page. Select the application and click Edit.

Note that if a session changes CSP applications during its life span, its timeout value will not be updated according to the default timeout defined in the application that the session moved into. For example, if a session starts out in CSP Application A, with a default timeout of 900 seconds, and then moves into CSP Application B, which has a default timeout of 1800 seconds, the session will still timeout after 900 seconds.

Check these points.
Still see the page parameter AUTOLOGOUT.

Exactly these are the settings for Auto Logout. This is working now after a fix from Intersystem

Vineeth, please help the community by accepting the answer that helped you. The animation in this article shows you how to do that.

Comments

On %CSP.Session

/// Specifies the timeout value for the session in seconds.
/// <P>If no user requests are received within the specified time period,
/// then the session will end. The default value comes from the CSP application
/// setting for the application that the session starts in which is set in the
/// Cache configuration manager, this is often 900 seconds or 15 minutes.
/// Note that if you start a session in one applicaiton and move to another application
/// the AppTimeout will not be changed to the new applications timeout value, if you wish
/// to modify this when the application changes you can use the session events 'OnApplicationChange'
/// method.
/// <P>For no timeout, set this property to 0.
Property AppTimeout As %Integer [ InitialExpression = 900 ];

You can also specify the timeout for your App as a whole:

 

<your server ip:57772>/csp/sys/sec/%25CSP.UI.Portal.Applications.Web.zen?PID=%2Fcsp%2Fuser